summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-03 18:36:31 -0500
committerMatt Turner <mattst88@gentoo.org>2021-04-08 21:33:28 -0400
commit42d26ac6b1a96927b46afa0d6681995393e9c509 (patch)
tree40c28a01c4c4de1c7475bc6383af2737c1455ced /dev-libs/cJSON/cJSON-1.7.14.ebuild
parentsci-mathematics/arb: new upstream version 2.19.0. (diff)
downloadgentoo-42d26ac6b1a96927b46afa0d6681995393e9c509.tar.gz
gentoo-42d26ac6b1a96927b46afa0d6681995393e9c509.tar.bz2
gentoo-42d26ac6b1a96927b46afa0d6681995393e9c509.zip
dev-libs/cJSON: Add new package
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/cJSON/cJSON-1.7.14.ebuild')
-rw-r--r--dev-libs/cJSON/cJSON-1.7.14.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/cJSON/cJSON-1.7.14.ebuild b/dev-libs/cJSON/cJSON-1.7.14.ebuild
new file mode 100644
index 000000000000..f720fd1b27f4
--- /dev/null
+++ b/dev-libs/cJSON/cJSON-1.7.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION=" Ultralightweight JSON parser in ANSI C"
+HOMEPAGE="https://github.com/DaveGamble/cJSON"
+SRC_URI="https://github.com/DaveGamble/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CJSON_TEST=$(usex test)
+ )
+
+ cmake_src_configure
+}