summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-10 15:14:07 +0000
committerSam James <sam@gentoo.org>2020-09-10 15:14:16 +0000
commite3002ff94b023e3c3028934d18bf95c4f055d80f (patch)
tree3348e061a6d9056c4f883e367fdfb560161c1c1f /dev-libs/botan
parentdev-perl/Filesys-SmbClient: -r bump for EAPI7 + misc toolchain love (diff)
downloadgentoo-e3002ff94b023e3c3028934d18bf95c4f055d80f.tar.gz
gentoo-e3002ff94b023e3c3028934d18bf95c4f055d80f.tar.bz2
gentoo-e3002ff94b023e3c3028934d18bf95c4f055d80f.zip
dev-libs/botan: security cleanup
Bug: https://bugs.gentoo.org/718596 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.9.0.ebuild103
-rw-r--r--dev-libs/botan/files/botan-2.9.0-build.patch63
3 files changed, 0 insertions, 167 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index ae7a46615519..a5442d2b4ff0 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,2 @@
DIST Botan-2.14.0.tar.xz 5958948 BLAKE2B 90e73945b22f6e4e8d6163bfb45eca153eb1495448f8bf35514b780fd12bb1b81c822314e1f598c7625277f1e9cf7a6265387cca80ffd4c2664c681b9d4807fd SHA512 ee15928ecdb0127720b444b0207d46fd68fe3007125b0deb8bdd32f96e9befb684ad54009354da4f6a3c48b9698693b46223710a47fd644da8760dda53d40d34
DIST Botan-2.15.0.tar.xz 5920688 BLAKE2B 1bbb9cadb0f754194851bddf8b14dbcd291285c5f3fbaad35920277a11c3d9e1b1e5cc484c0d37b1c7999b3084a1c90da56631df0b07e788372b95aff5197031 SHA512 0965a0a6141df44e38bd7da038b89dd2b3808ed9a4ebaafbf089abf60718e62cba78d7b64eaf272b5df8c5a489222e4cad4fb511cde38e76cdaed87f35896c18
-DIST Botan-2.9.0.tgz 7216373 BLAKE2B 5ad2e15db871ccc3a32b29b7f54a02d69f251f0aca2ce656b557dbbb3814a793053a54905371b3414ad72952a64bece43e2383da91f205f68b0fe31be2f9439c SHA512 b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65
diff --git a/dev-libs/botan/botan-2.9.0.ebuild b/dev-libs/botan/botan-2.9.0.ebuild
deleted file mode 100644
index ec3daddb3301..000000000000
--- a/dev-libs/botan/botan-2.9.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-SLOT="2/$(ver_cut 1-2)" # soname version
-LICENSE="BSD"
-IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}
- bzip2? ( >=app-arch/bzip2-1.0.5:= )
- zlib? ( >=sys-libs/zlib-1.2.3:= )
- boost? ( >=dev-libs/boost-1.48:= )
- lzma? ( app-arch/xz-utils:= )
- sqlite? ( dev-db/sqlite:3= )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )"
-BDEPEND="dev-lang/python:*
- doc? ( dev-python/sphinx )"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-src_configure() {
- local disable_modules=()
- use boost || disable_modules+=( "boost" )
- use bindist && disable_modules+=( "ecdsa" )
- elog "Disabling modules: ${disable_modules[@]}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- case ${CHOST} in
- hppa*) CHOSTARCH=parisc ;;
- esac
-
- local pythonvers=()
- if use python; then
- append() {
- pythonvers+=( ${EPYTHON/python/} )
- }
- python_foreach_impl append
- fi
-
- CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
- $(use_enable static-libs static-library) \
- $(use_with boost) \
- $(use_with bzip2) \
- $(use_with doc documentation) \
- $(use_with doc sphinx) \
- $(use_with lzma) \
- $(use_with sqlite sqlite3) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- $(usex hppa --without-stack-protector '') \
- --cc=gcc \
- --cpu=${CHOSTARCH} \
- --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
- --docdir=share/doc \
- --libdir=$(get_libdir) \
- --os=${myos} \
- --prefix="${EPREFIX}/usr" \
- --with-endian="$(tc-endian)" \
- --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
- --without-doxygen \
- || die "configure.py failed"
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
- default
- use python && python_foreach_impl python_optimize
-}
diff --git a/dev-libs/botan/files/botan-2.9.0-build.patch b/dev-libs/botan/files/botan-2.9.0-build.patch
deleted file mode 100644
index 6208ffdbf0ad..000000000000
--- a/dev-libs/botan/files/botan-2.9.0-build.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 86df247e4f090f984e050962ed5a4a536ec63b33 Mon Sep 17 00:00:00 2001
-From: Ralf van der Enden <Ralf.vanderEnden@deltares.nl>
-Date: Fri, 5 Apr 2019 14:58:14 +0200
-Subject: [PATCH] boost 1.70 compatibility
-
-Fixes issue #82
----
- src/cli/tls_http_server.cpp | 8 +++++++-
- src/cli/tls_proxy.cpp | 8 +++++++-
- 2 files changed, 14 insertions(+), 2 deletions(-)
-
-diff --git a/src/cli/tls_http_server.cpp b/src/cli/tls_http_server.cpp
-index cc59a71c33..0a6428cd65 100644
---- a/src/cli/tls_http_server.cpp
-+++ b/src/cli/tls_http_server.cpp
-@@ -41,6 +41,12 @@
-
- #include "credentials.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace Botan_CLI {
-
- namespace {
-@@ -435,7 +441,7 @@ class TLS_Asio_HTTP_Server final
- session::pointer make_session()
- {
- return session::create(
-- m_acceptor.get_io_service(),
-+ GET_IO_SERVICE(m_acceptor),
- m_session_manager,
- m_creds,
- m_policy);
-diff --git a/src/cli/tls_proxy.cpp b/src/cli/tls_proxy.cpp
-index 49ffbe3766..42ce156b12 100644
---- a/src/cli/tls_proxy.cpp
-+++ b/src/cli/tls_proxy.cpp
-@@ -33,6 +33,12 @@
-
- #include "credentials.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace Botan_CLI {
-
- namespace {
-@@ -370,7 +376,7 @@ class tls_proxy_server final
- session::pointer make_session()
- {
- return session::create(
-- m_acceptor.get_io_service(),
-+ GET_IO_SERVICE(m_acceptor),
- m_session_manager,
- m_creds,
- m_policy,