summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-31 12:13:58 +0000
committerSam James <sam@gentoo.org>2021-05-31 12:14:56 +0000
commite420d181a07a0dcfef293eb85dc299511daf85cd (patch)
treee47f4e337465ddaeb2b92d1b3347b9f340201c4d /dev-libs/boost
parentdev-python/zope-component: bump to python 3.10 (diff)
downloadgentoo-e420d181a07a0dcfef293eb85dc299511daf85cd.tar.gz
gentoo-e420d181a07a0dcfef293eb85dc299511daf85cd.tar.bz2
gentoo-e420d181a07a0dcfef293eb85dc299511daf85cd.zip
dev-libs/boost: add patch to fix build (a typo) on sparc
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.76.0-r1.ebuild1
-rw-r--r--dev-libs/boost/files/boost-1.76-sparc-define.patch21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.76.0-r1.ebuild b/dev-libs/boost/boost-1.76.0-r1.ebuild
index 16bc039e2269..888357388182 100644
--- a/dev-libs/boost/boost-1.76.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.76.0-r1.ebuild
@@ -55,6 +55,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.73-boost-mpi-python-PEP-328.patch
"${FILESDIR}"/${PN}-1.74-CVE-2012-2677.patch
"${FILESDIR}"/${PN}-1.76-boost-numpy.patch
+ "${FILESDIR}"/${PN}-1.76-sparc-define.patch
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.76-sparc-define.patch b/dev-libs/boost/files/boost-1.76-sparc-define.patch
new file mode 100644
index 000000000000..b3909ee31376
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.76-sparc-define.patch
@@ -0,0 +1,21 @@
+https://github.com/boostorg/predef/commit/1be0e4a2d8db15a405f64a6f65507b87c1be7e1a.patch
+
+From 1be0e4a2d8db15a405f64a6f65507b87c1be7e1a Mon Sep 17 00:00:00 2001
+From: tkoecker <tkoecker@gmx.net>
+Date: Fri, 21 May 2021 16:31:11 +0200
+Subject: [PATCH] added missing brackets (#118)
+--- a/boost/predef/architecture/sparc.h
++++ b/boost/predef/architecture/sparc.h
+@@ -34,10 +34,10 @@ Distributed under the Boost Software License, Version 1.0.
+
+ #if defined(__sparc__) || defined(__sparc)
+ # undef BOOST_ARCH_SPARC
+-# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv9) || defined(__sparc_v9__)
++# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv9) || defined(__sparc_v9__))
+ # define BOOST_ARCH_SPARC BOOST_VERSION_NUMBER(9,0,0)
+ # endif
+-# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv8) || defined(__sparc_v8__)
++# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv8) || defined(__sparc_v8__))
+ # define BOOST_ARCH_SPARC BOOST_VERSION_NUMBER(8,0,0)
+ # endif
+ # if !defined(BOOST_ARCH_SPARC)