summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-12 00:14:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-12 00:23:13 +0100
commit5424ae7d183c99806f3361207d4f3ba2bfa6ef71 (patch)
treee1deef810d01876eec082a60d8fc37e39ece6041 /dev-lang
parentdev-lang/closure-compiler-bin: update metadata; take up maintainership (diff)
downloadgentoo-5424ae7d183c99806f3361207d4f3ba2bfa6ef71.tar.gz
gentoo-5424ae7d183c99806f3361207d4f3ba2bfa6ef71.tar.bz2
gentoo-5424ae7d183c99806f3361207d4f3ba2bfa6ef71.zip
dev-lang/closure-compiler-bin: bump to EAPI 8; tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/closure-compiler-bin/closure-compiler-bin-20211107-r1.ebuild (renamed from dev-lang/closure-compiler-bin/closure-compiler-bin-20211107.ebuild)27
1 files changed, 16 insertions, 11 deletions
diff --git a/dev-lang/closure-compiler-bin/closure-compiler-bin-20211107.ebuild b/dev-lang/closure-compiler-bin/closure-compiler-bin-20211107-r1.ebuild
index caecdb89ffdd..1790b462aa70 100644
--- a/dev-lang/closure-compiler-bin/closure-compiler-bin-20211107.ebuild
+++ b/dev-lang/closure-compiler-bin/closure-compiler-bin-20211107-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit java-pkg-2
@@ -9,16 +9,18 @@ MY_PN="${PN%-bin}"
MY_P="${MY_PN}-v${PV}"
DESCRIPTION="JavaScript optimizing compiler"
-HOMEPAGE="https://developers.google.com/closure/compiler/ https://github.com/google/closure-compiler"
+HOMEPAGE="https://developers.google.com/closure/compiler/
+ https://github.com/google/closure-compiler/"
SRC_URI="https://repo1.maven.org/maven2/com/google/javascript/${MY_PN}/v${PV}/${MY_P}.jar"
+S="${WORKDIR}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=virtual/jre-1.8"
-
-S="${WORKDIR}"
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
src_unpack() {
:
@@ -29,10 +31,13 @@ src_compile() {
}
src_install() {
- java-pkg_jarinto /opt/${PN}-${SLOT}/lib
- java-pkg_newjar "${DISTDIR}"/${MY_P}.jar ${PN}.jar
- java-pkg_dolauncher \
- ${MY_PN} \
- --jar /opt/${PN}-${SLOT}/lib/${PN}.jar \
+ java-pkg_jarinto "/opt/${PN}-${SLOT}/lib"
+ java-pkg_newjar "${DISTDIR}/${MY_P}.jar" "${PN}.jar"
+
+ local -a dolauncher_opts=(
+ "${MY_PN}"
+ --jar "/opt/${PN}-${SLOT}/lib/${PN}.jar"
-into /opt
+ )
+ java-pkg_dolauncher "${dolauncher_opts[@]}"
}