summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-22 10:40:15 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-22 10:41:07 -0500
commit141168bb010c32538eec0b78501dfda0abf3e5bf (patch)
tree21ef49e1a814bf072e82200e3353487bc35708ab /dev-lang
parentmedia-sound/aumix: Fixed build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-141168bb010c32538eec0b78501dfda0abf3e5bf.tar.gz
gentoo-141168bb010c32538eec0b78501dfda0abf3e5bf.tar.bz2
gentoo-141168bb010c32538eec0b78501dfda0abf3e5bf.zip
dev-lang/go: document the reason we download all bootstrap archives
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-1.12.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.12.1.ebuild b/dev-lang/go/go-1.12.1.ebuild
index 0a21a156b985..1426dfb091d9 100644
--- a/dev-lang/go/go-1.12.1.ebuild
+++ b/dev-lang/go/go-1.12.1.ebuild
@@ -10,8 +10,8 @@ MY_PV=${PV/_/}
inherit toolchain-funcs
-BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
BOOTSTRAP_VERSION="bootstrap-1.8"
+BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
BOOTSTRAP_URI="
${BOOTSTRAP_DIST}/go-linux-amd64-${BOOTSTRAP_VERSION}.tbz
${BOOTSTRAP_DIST}/go-linux-arm-${BOOTSTRAP_VERSION}.tbz
@@ -47,6 +47,13 @@ case ${PV} in
;;
esac
esac
+
+# If gccgo is not being used to build Go, there is no way to know the
+# architecture or operating system of the build machine, so we need to
+# download all of our bootstrap archives to allow this ebuild to work
+# under crossdev.
+#
+# https://bugs.gentoo.org/671394
SRC_URI+="!gccgo? ( ${BOOTSTRAP_URI} )"
DESCRIPTION="A concurrent garbage collected and typesafe programming language"