summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-25 13:34:24 +0100
committerSam James <sam@gentoo.org>2021-10-25 13:35:11 +0100
commit717eba5b5cfb78b1438c348882b34c88b3dc173a (patch)
treed603241371a01b2c5920e7528f70026b56bb586b /dev-lang/tcc
parentapp-misc/physlock: Add patch to set PAM_TTY (diff)
downloadgentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.tar.gz
gentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.tar.bz2
gentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.zip
dev-lang/tcc: add 0.9.27_p20211022 (glibc-2.34, security fixes)
Upstream development seems to just be rolling now too. Closes: https://bugs.gentoo.org/806511 Bug: https://bugs.gentoo.org/737092 Bug: https://bugs.gentoo.org/715428 Bug: https://bugs.gentoo.org/765652 Bug: https://bugs.gentoo.org/687114 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/tcc')
-rw-r--r--dev-lang/tcc/Manifest1
-rw-r--r--dev-lang/tcc/tcc-0.9.27_p20211022.ebuild80
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild43
3 files changed, 106 insertions, 18 deletions
diff --git a/dev-lang/tcc/Manifest b/dev-lang/tcc/Manifest
index 170ccf6bd979..fb3b05d6eecc 100644
--- a/dev-lang/tcc/Manifest
+++ b/dev-lang/tcc/Manifest
@@ -1 +1,2 @@
DIST tcc-0.9.27.tar.bz2 634999 BLAKE2B 9a76dac9f54fa0b64a72e874cfec9a4bd9b938d244d064b2e76bd31acfb9e48fdbdb8895132634be1dee4302293405bf75606a6804c8178afa8fd30daa53b73a SHA512 835184292d97c07f0ff7b36ec550e855e649b04e23c7e2a1c706d223409eb60708dc1ae969f28eba45e56c8b96ae56936b93caf9d8a13ac5adf119014d5367a7
+DIST tcc-0.9.27_p20211022.tar.gz 893631 BLAKE2B f1a82498db65a9944f04a6c35897db6ceeea0e5d14ac383acc6b334fb2aa921a0e7b4badf647c101d064ceae1ee8d79ab91674a2d0faa2899b831a57e6148174 SHA512 5f40a0d31d63e876d1fb233758d9f58be2f14807bbc0847b7df3eb6bb8df0946100b58edb5a29caea8770201d02275daf0a3ca7668141151e931204ad7100fb3
diff --git a/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
new file mode 100644
index 000000000000..f53743b5e6b9
--- /dev/null
+++ b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
+DESCRIPTION="A very small C compiler for ix86/amd64"
+HOMEPAGE="https://bellard.org/tcc/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://repo.or.cz/r/tinycc.git"
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://repo.or.cz/tinycc.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/tinycc-1645616
+else
+ SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+BDEPEND="dev-lang/perl" # doc generation
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ # Don't strip
+ sed -i \
+ -e 's|$(INSTALL) -s|$(INSTALL)|' \
+ -e 's|STRIP_yes = -s|STRIP_yes =|' \
+ Makefile || die
+
+ # Fix examples
+ sed -i -e '1{
+ i#! /usr/bin/tcc -run
+ /^#!/d
+ }' examples/ex*.c || die
+ sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
+
+ # Fix texi2html invocation
+ sed -i -e 's/-number//' Makefile || die
+ sed -i -e 's/--sections//' Makefile || die
+}
+
+src_configure() {
+ use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
+ # better fixes welcome, it feels wrong to hack the env like this
+
+ # not autotools, so call configure directly
+ ./configure --cc="$(tc-getCC)" \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_test() {
+ # this is using tcc bits that don't know as-needed etc.
+ TCCFLAGS="" emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc Changelog README TODO VERSION
+ #dohtml tcc-doc.html
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/ex*.c
+}
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index 5aa530ef3af5..f53743b5e6b9 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,34 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
+inherit toolchain-funcs
+
+MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
HOMEPAGE="https://bellard.org/tcc/"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://repo.or.cz/r/tinycc.git"
- SRC_URI=""
- scm_eclass=git-r3
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://repo.or.cz/tinycc.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/tinycc-1645616
else
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
fi
-inherit toolchain-funcs ${scm_eclass}
-
LICENSE="LGPL-2.1"
SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
-DEPEND="dev-lang/perl" # doc generation
-# Both tendra and tinycc install /usr/bin/tcc
-RDEPEND="!dev-lang/tendra"
+BDEPEND="dev-lang/perl" # doc generation
IUSE="test"
RESTRICT="!test? ( test )"
src_prepare() {
+ default
+
# Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
+ sed -i \
+ -e 's|$(INSTALL) -s|$(INSTALL)|' \
+ -e 's|STRIP_yes = -s|STRIP_yes =|' \
+ Makefile || die
# Fix examples
sed -i -e '1{
@@ -37,16 +45,15 @@ src_prepare() {
}' examples/ex*.c || die
sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
- # fix texi2html invocation
+ # Fix texi2html invocation
sed -i -e 's/-number//' Makefile || die
sed -i -e 's/--sections//' Makefile || die
-
- eapply_user
}
src_configure() {
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
# better fixes welcome, it feels wrong to hack the env like this
+
# not autotools, so call configure directly
./configure --cc="$(tc-getCC)" \
--prefix="${EPREFIX}/usr" \
@@ -58,6 +65,11 @@ src_compile() {
emake AR="$(tc-getAR)"
}
+src_test() {
+ # this is using tcc bits that don't know as-needed etc.
+ TCCFLAGS="" emake test
+}
+
src_install() {
emake DESTDIR="${D}" install
@@ -66,8 +78,3 @@ src_install() {
exeinto /usr/share/doc/${PF}/examples
doexe examples/ex*.c
}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}