summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 18:28:31 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 18:28:31 -0800
commitc73cccd08d985b6d5841a5db772e2903cf8335dc (patch)
tree44ff0a7587d9ec907bfcb99427081b2d08470019 /dev-lang/jsonnet
parentdev-lang/jsonnet-0.14.0-r1: Revbump, add py38 (diff)
downloadgentoo-c73cccd08d985b6d5841a5db772e2903cf8335dc.tar.gz
gentoo-c73cccd08d985b6d5841a5db772e2903cf8335dc.tar.bz2
gentoo-c73cccd08d985b6d5841a5db772e2903cf8335dc.zip
dev-lang/jsonnet: Remove old
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet')
-rw-r--r--dev-lang/jsonnet/Manifest2
-rw-r--r--dev-lang/jsonnet/jsonnet-0.12.1.ebuild56
-rw-r--r--dev-lang/jsonnet/jsonnet-0.13.0.ebuild61
3 files changed, 0 insertions, 119 deletions
diff --git a/dev-lang/jsonnet/Manifest b/dev-lang/jsonnet/Manifest
index 16e59487bbd7..153d5221f36f 100644
--- a/dev-lang/jsonnet/Manifest
+++ b/dev-lang/jsonnet/Manifest
@@ -1,3 +1 @@
-DIST jsonnet-0.12.1.tar.gz 21839349 BLAKE2B 8601a35263003723b435d0075fe60f5301a49bddf63cdd55958df3eb7474569c28dbf54e0ba9d07fb6ade395af725193d1432b2c43fb2b271531af179e850df4 SHA512 25523dd19b4209a5ca39275ab3d3726b934442dd83a965ab0b79f0c67bd8ae85c438b2a63990b8eec921b137f908f946696be331b08cef92f15b6b8fa548cb0d
-DIST jsonnet-0.13.0.tar.gz 21850449 BLAKE2B fa0665d63b09dfc01a7454268d6edd467524cdfdb5d53e838665f046f1f08608c493503a88d7af7e26c3dc07e0ae4323753affab90c5ac41c27ebe8b7b39a4a0 SHA512 d19e5398763e37b79b0ef02368f6bd6215d2df234b5ff7a6d98e2306a0d47290600061c9f868c0c262570b4f0ee9eee6c309bcc93937b12f6c14f8d12339a7d5
DIST jsonnet-0.14.0.tar.gz 21857157 BLAKE2B 93de74fa07efa300097ccb9503b41543beb749d5aff130ad9a6139a3ceb0a07b404aa50877d4cbacd9eb26b2194d8cd9bf578521f17f84a3480655b179525663 SHA512 e09fb27202a34e88134d98d59fdccd4f1ee777e7c8090c3687cb5c11b9ada3bfe7b878322e0274743694ff77457215484470ccf90d03d9d36159288e5a18ab0b
diff --git a/dev-lang/jsonnet/jsonnet-0.12.1.ebuild b/dev-lang/jsonnet/jsonnet-0.12.1.ebuild
deleted file mode 100644
index 4ba4fd82bda9..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.12.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit toolchain-funcs distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers "
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="python? ( ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.12.1-makefile.patch"
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
- "${FILESDIR}/jsonnet-0.13.0-glibc-2.29.patch"
-)
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
- use python && distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test || die
-}
-
-src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
- use python && distutils-r1_src_install
-}
diff --git a/dev-lang/jsonnet/jsonnet-0.13.0.ebuild b/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
deleted file mode 100644
index bb16ecea1cd1..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit toolchain-funcs distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers "
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="python? ( ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.12.1-makefile.patch"
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
- "${FILESDIR}/jsonnet-0.13.0-glibc-2.29.patch"
-)
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
- use python && distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test || die
-}
-
-src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
- use python && distutils-r1_src_install
-}