summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-10 11:34:30 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-10 11:34:48 -0800
commit5a2ebc4ed6dd8ffb6f74edc296920db419e36d74 (patch)
treed4d82be59812105951f8f8b268f7bfaaed9d2642 /dev-lang/jsonnet
parentdev-lang/jsonnet-0.15.0: Version bump (diff)
downloadgentoo-5a2ebc4ed6dd8ffb6f74edc296920db419e36d74.tar.gz
gentoo-5a2ebc4ed6dd8ffb6f74edc296920db419e36d74.tar.bz2
gentoo-5a2ebc4ed6dd8ffb6f74edc296920db419e36d74.zip
dev-lang/jsonnet: remove old
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet')
-rw-r--r--dev-lang/jsonnet/Manifest1
-rw-r--r--dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild63
-rw-r--r--dev-lang/jsonnet/jsonnet-0.14.0.ebuild65
3 files changed, 0 insertions, 129 deletions
diff --git a/dev-lang/jsonnet/Manifest b/dev-lang/jsonnet/Manifest
index 20e5e8a628b1..f8ff10813b5a 100644
--- a/dev-lang/jsonnet/Manifest
+++ b/dev-lang/jsonnet/Manifest
@@ -1,2 +1 @@
-DIST jsonnet-0.14.0.tar.gz 21857157 BLAKE2B 93de74fa07efa300097ccb9503b41543beb749d5aff130ad9a6139a3ceb0a07b404aa50877d4cbacd9eb26b2194d8cd9bf578521f17f84a3480655b179525663 SHA512 e09fb27202a34e88134d98d59fdccd4f1ee777e7c8090c3687cb5c11b9ada3bfe7b878322e0274743694ff77457215484470ccf90d03d9d36159288e5a18ab0b
DIST jsonnet-0.15.0.tar.gz 21826038 BLAKE2B 722a844c00ec31b662d932a4481a71197adad680181c6a56a49dfa3e9b63696d29320c5278024d44c0ab3d7d80569514792f815ac7fa3a3cc08c7756fb6f08ad SHA512 b63c1bf82e4fc9ba3f1009ed4e4ba1010e3e7f81bd816a234e48d35607eae3cba95cab57813d35daa9f024e316bae5256340a6f8d6d884f9136cdbf062a2b351
diff --git a/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild b/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild
deleted file mode 100644
index ea949946fb6a..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.14.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_6 python3_{7,8} )
-
-inherit toolchain-funcs flag-o-matic distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers "
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="python? ( ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
-)
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- use custom-optimization || replace-flags '-O*' -O3
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
- use python && distutils-r1_src_test
-}
-
-src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
- use python && distutils-r1_src_install
-}
diff --git a/dev-lang/jsonnet/jsonnet-0.14.0.ebuild b/dev-lang/jsonnet/jsonnet-0.14.0.ebuild
deleted file mode 100644
index 6c941fab0926..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.14.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit toolchain-funcs flag-o-matic distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers "
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="python? ( ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
-)
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- use custom-optimization || replace-flags '-O*' -O3
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
- use python && distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test || die
-}
-
-src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
- use python && distutils-r1_src_install
-}