summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-20 00:51:08 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-20 00:51:08 +0200
commitad141ad909c0f860e0cebe8ee9d5714eabc30141 (patch)
tree025c14b3c747759948a37bfbab08450e24e58bfb /dev-lang/bas
parentdev-lang/regina-rexx: Port to EAPI 7 (diff)
downloadgentoo-ad141ad909c0f860e0cebe8ee9d5714eabc30141.tar.gz
gentoo-ad141ad909c0f860e0cebe8ee9d5714eabc30141.tar.bz2
gentoo-ad141ad909c0f860e0cebe8ee9d5714eabc30141.zip
dev-lang/bas: Port to EAPI 7
Closes: https://bugs.gentoo.org/632438 Closes: https://bugs.gentoo.org/740956 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/bas')
-rw-r--r--dev-lang/bas/bas-2.4.ebuild32
-rw-r--r--dev-lang/bas/files/bas-2.1-makefile.patch4
2 files changed, 19 insertions, 17 deletions
diff --git a/dev-lang/bas/bas-2.4.ebuild b/dev-lang/bas/bas-2.4.ebuild
index 6e07253f7a6e..30a9f6103abf 100644
--- a/dev-lang/bas/bas-2.4.ebuild
+++ b/dev-lang/bas/bas-2.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils toolchain-funcs
+EAPI=7
+
+inherit autotools toolchain-funcs
DESCRIPTION="An interpreter for the classic dialect of the programming language BASIC"
HOMEPAGE="http://www.moria.de/~michael/bas/"
@@ -13,27 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lr0"
-RDEPEND="sys-libs/ncurses
+RDEPEND="
+ sys-libs/ncurses
virtual/libintl"
-DEPEND="${RDEPEND}
- sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.1-makefile.patch
+PATCHES=( "${FILESDIR}"/${PN}-2.1-makefile.patch )
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoconf
}
src_configure() {
tc-export AR
- econf \
- $(use_enable lr0)
+ econf $(use_enable lr0)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc NEWS README
- insinto /usr/share/doc/${PF}/pdf
- doins bas.pdf
+ default
+
+ docinto pdf
+ dodoc bas.pdf
}
diff --git a/dev-lang/bas/files/bas-2.1-makefile.patch b/dev-lang/bas/files/bas-2.1-makefile.patch
index 3be4bb09eafa..904ce3abcb42 100644
--- a/dev-lang/bas/files/bas-2.1-makefile.patch
+++ b/dev-lang/bas/files/bas-2.1-makefile.patch
@@ -4,8 +4,8 @@ Fixes makefile.in to respect AR during libbas build
Patch by Kevin McCarthy <signals42@gmail.com>
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -27,7 +27,7 @@
libbas.a: auto.o bas.o fs.o global.o token.o program.o \
str.o value.o var.o