summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-11-20 12:03:17 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-11-24 12:14:28 +0100
commit3ff9b62d2089b461d77771f920c37689e01d88a7 (patch)
tree2e9fe4ab3319897b8d4e29d2ab5e4e89298b5a09 /dev-java
parentapp-editors/xmlcopyeditor: add 1.3.1.0 (diff)
downloadgentoo-3ff9b62d2089b461d77771f920c37689e01d88a7.tar.gz
gentoo-3ff9b62d2089b461d77771f920c37689e01d88a7.tar.bz2
gentoo-3ff9b62d2089b461d77771f920c37689e01d88a7.zip
dev-java/eclipse-ecj: fix runtime error (slot 4.27)
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-4.27-r1.ebuild (renamed from dev-java/eclipse-ecj/eclipse-ecj-4.27.ebuild)26
1 files changed, 17 insertions, 9 deletions
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-4.27.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-4.27-r1.ebuild
index fb56b1b9116c..0c8b3763125d 100644
--- a/dev-java/eclipse-ecj/eclipse-ecj-4.27.ebuild
+++ b/dev-java/eclipse-ecj/eclipse-ecj-4.27-r1.ebuild
@@ -20,20 +20,22 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
SLOT="4.27"
IUSE="+ant"
-COMMON_DEP="
- app-eselect/eselect-java
- dev-java/ant-core:0"
+BDEPEND="
+ app-arch/unzip
+ app-arch/zip"
+COMMON_DEP="app-eselect/eselect-java"
# ElementsImpl9.java:206: error:
# method does not override or implement a method from a supertype
DEPEND="${COMMON_DEP}
- >=virtual/jdk-21:*
- app-arch/unzip"
+ dev-java/ant-core:0
+ >=virtual/jdk-21:*"
RDEPEND="${COMMON_DEP}
>=virtual/jre-11:*"
-PDEPEND="
- ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+PDEPEND="ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
-JAVA_GENTOO_CLASSPATH="ant-core"
+DOCS=( org/eclipse/jdt/core/README.md )
+
+JAVA_CLASSPATH_EXTRA="ant-core"
JAVA_JAR_FILENAME="${MY_PN}.jar"
JAVA_LAUNCHER_FILENAME="${MY_PN}-${SLOT}"
JAVA_MAIN_CLASS="org.eclipse.jdt.internal.compiler.batch.Main"
@@ -48,11 +50,17 @@ src_prepare() {
rm -r org/eclipse/jdt/internal/antadapter || die
mkdir "${JAVA_RESOURCE_DIRS}" || die
- find -type f \
+ find org META-INF -type f \
! -name '*.java' \
| xargs cp --parent -t "${JAVA_RESOURCE_DIRS}" || die
}
+src_compile() {
+ java-pkg-simple_src_compile
+ # Error: A JNI error has occurred, please check your installation and try again
+ zip -d ecj.jar "META-INF/MANIFEST.MF" || die "Failed to remove MANIFEST.MF"
+}
+
pkg_postinst() {
einfo "To select between slots of ECJ..."
einfo " # eselect ecj"