summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-02-13 17:25:54 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-03-15 11:14:45 +0100
commit4f0892e15a77b4facb3495b15a56dfa33a33dc6d (patch)
treef869e272f61f474280696c2f9af42b38b035e7bf /dev-java/tomcat-native
parentdev-java/commons-compress: add 1.26.1 (diff)
downloadgentoo-4f0892e15a77b4facb3495b15a56dfa33a33dc6d.tar.gz
gentoo-4f0892e15a77b4facb3495b15a56dfa33a33dc6d.tar.bz2
gentoo-4f0892e15a77b4facb3495b15a56dfa33a33dc6d.zip
dev-java/tomcat-native: add slibtool.patch
Closes: https://bugs.gentoo.org/924337 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/files/tomcat-native-1.2.39-slibtool.patch26
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.2.39.ebuild4
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/files/tomcat-native-1.2.39-slibtool.patch b/dev-java/tomcat-native/files/tomcat-native-1.2.39-slibtool.patch
new file mode 100644
index 000000000000..e193a0ffd905
--- /dev/null
+++ b/dev-java/tomcat-native/files/tomcat-native-1.2.39-slibtool.patch
@@ -0,0 +1,26 @@
+From 54dccd3a4dc01801d9311b3160808305ec9fc2cf Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 21 Jul 2022 17:59:14 -0700
+Subject: [PATCH] native: Fix the build with rlibtool
+
+When building tomcat-native with slibtool using the rlibtool symlink the
+build will fail. This is because rlibtool requires the generated libtool
+script to determine if the build is shared, static or both.
+
+Gentoo bug: https://bugs.gentoo.org/778914
+---
+ native/configure.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- a/configure.in
++++ b/configure.in
+@@ -50,6 +50,9 @@ AC_SUBST(TCN_CONFIG_LOCATION)
+ AC_CANONICAL_TARGET
+ AC_PROG_INSTALL
+
++dnl Generate the libtool script which is needed for rlibtool
++LT_INIT
++
+ dnl
+ dnl compute the top directory of the build
+ dnl note: this is needed for LIBTOOL and exporting the bundled Expat
diff --git a/dev-java/tomcat-native/tomcat-native-1.2.39.ebuild b/dev-java/tomcat-native/tomcat-native-1.2.39.ebuild
index 5d246c6ecdab..e1e3cd36a857 100644
--- a/dev-java/tomcat-native/tomcat-native-1.2.39.ebuild
+++ b/dev-java/tomcat-native/tomcat-native-1.2.39.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,8 +38,10 @@ JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="../test"
DOCS=( ../{CHANGELOG.txt,NOTICE,README.txt} )
+PATCHES=( "${FILESDIR}/tomcat-native-1.2.39-slibtool.patch" )
src_prepare() {
+ default #780585
java-pkg-2_src_prepare
mkdir -p "${JAVA_RESOURCE_DIRS}/META-INF" || die
sed -ne '/attribute name/s:^.*name="\(.*\)" value="\(.*\)".*$:\1\: \2:p' \