summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-03 17:13:27 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-03 21:19:06 +0000
commitd718007741f4865466524b0bce10323a0112de59 (patch)
treeffdd324857f2838f7ce69c3de3132e1a197fc59c /dev-java/osgi-core-api
parentdev-java/log4j: Clean up unused USE flag. (diff)
downloadgentoo-d718007741f4865466524b0bce10323a0112de59.tar.gz
gentoo-d718007741f4865466524b0bce10323a0112de59.tar.bz2
gentoo-d718007741f4865466524b0bce10323a0112de59.zip
dev-java/osgi-core-api: EAPI 5 bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/osgi-core-api')
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild
new file mode 100644
index 000000000000..30ac8b1056be
--- /dev/null
+++ b/dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+java_prepare() {
+ rm -r org || die
+}