summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/nailgun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/nailgun')
-rw-r--r--dev-java/nailgun/Manifest1
-rw-r--r--dev-java/nailgun/files/0.7.1-r1-Makefile.patch18
-rw-r--r--dev-java/nailgun/metadata.xml11
-rw-r--r--dev-java/nailgun/nailgun-0.7.1-r1.ebuild67
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-java/nailgun/Manifest b/dev-java/nailgun/Manifest
new file mode 100644
index 000000000000..0a2a84d95ca1
--- /dev/null
+++ b/dev-java/nailgun/Manifest
@@ -0,0 +1 @@
+DIST nailgun-src-0.7.1.zip 1489813 SHA256 2942760e68fabab1afc3bc447545cb532ae7bd6e779ca4af8b3163d629076e72 SHA512 51867248179487b042f3fe93585390b972d1d95928f92fc6b342c3ae663696b251fcd074c8042c6ae129947105e2203cb256a987b46dd8499bb3964302f1ccae WHIRLPOOL 7c24f82a260eaef397fc694f5e15abfe86c2463d644366bf4d59904cf632e301ec5c9f26d0a63aff4491c196bbf3b8dfa612862e59d488eaf3af6076abacd1d8
diff --git a/dev-java/nailgun/files/0.7.1-r1-Makefile.patch b/dev-java/nailgun/files/0.7.1-r1-Makefile.patch
new file mode 100644
index 000000000000..a38185485578
--- /dev/null
+++ b/dev-java/nailgun/files/0.7.1-r1-Makefile.patch
@@ -0,0 +1,18 @@
+diff -Naur nailgun-0.7.1/Makefile nailgun-0.7.1_patches/Makefile
+--- nailgun-0.7.1/Makefile 2004-11-25 11:00:22.000000000 +1300
++++ nailgun-0.7.1_patches/Makefile 2012-04-19 07:22:16.000000000 +1200
+@@ -5,13 +5,11 @@
+ #
+ # Marty Lamb
+
+-CC=gcc
+ WIN32_CC=/usr/local/mingw32/bin/mingw32-gcc
+-CFLAGS=-Wall -pedantic -s -O3
+
+ ng: src/c/ng.c
+ @echo "Building ng client. To build a Windows binary, type 'make ng.exe'"
+- ${CC} ${CFLAGS} -o ng src/c/ng.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o ng src/c/ng.c
+
+ ng.exe: src/c/ng.c
+ # any idea why the command line is so sensitive to the order of
diff --git a/dev-java/nailgun/metadata.xml b/dev-java/nailgun/metadata.xml
new file mode 100644
index 000000000000..b25a04437581
--- /dev/null
+++ b/dev-java/nailgun/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ Nailgun is a client, protocol, and server for running Java programs from the command line without incurring the JVM startup overhead. Programs run in the server (which is implemented in Java), and are triggered by the client (written in C), which handles all I/O.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nailgun</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/nailgun/nailgun-0.7.1-r1.ebuild b/dev-java/nailgun/nailgun-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..bc61ac38f0e6
--- /dev/null
+++ b/dev-java/nailgun/nailgun-0.7.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="a client, protocol, and server for running Java apps without incurring the JVM startup overhead"
+HOMEPAGE="http://martiansoftware.com/nailgun/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.4
+ !app-editors/ng"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/java-getopt:1
+ dev-java/bcel:0
+ dev-java/jakarta-oro:2.0
+ dev-java/log4j:0
+ app-arch/unzip
+ dev-java/junit:0
+ test? (
+ dev-java/ant-junit:0
+ )"
+
+#need jcoverage
+RESTRICT="test"
+
+java_prepare() {
+ rm -vf ng* beansh
+ find . -iname '*.jar' -delete
+
+ epatch "${FILESDIR}/${PV}-r1-Makefile.patch"
+
+ sed -i '/<arg line="ng.exe/d' build.xml || die
+ sed -i 's/depends="test"/depends="compile"/' build.xml || die
+
+ java-pkg_jar-from --into tools/lib --build-only java-getopt-1 \
+ gnu.getopt.jar java-getopt-1.0.10.jar
+ java-pkg_jar-from --into tools/lib --build-only junit junit.jar
+ java-pkg_jar-from --into tools/lib --build-only bcel bcel.jar \
+ bcel-5.1.jar
+ java-pkg_jar-from --into tools/lib --build-only jakarta-oro-2.0 \
+ jakarta-oro.jar jakarta-oro-2.0.8.jar
+ java-pkg_jar-from --into tools/lib --build-only log4j log4j.jar \
+ log4j-1.2.8.jar
+}
+
+src_test() {
+ WANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ dobin ng
+ # Should we have a dolauncher?
+
+ java-pkg_newjar "dist/${P}.jar"
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/java/prod/*
+}