summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jvyamlb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jvyamlb')
-rw-r--r--dev-java/jvyamlb/Manifest1
-rw-r--r--dev-java/jvyamlb/jvyamlb-0.2.5.ebuild46
-rw-r--r--dev-java/jvyamlb/metadata.xml11
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/jvyamlb/Manifest b/dev-java/jvyamlb/Manifest
new file mode 100644
index 000000000000..035759b93b05
--- /dev/null
+++ b/dev-java/jvyamlb/Manifest
@@ -0,0 +1 @@
+DIST jvyamlb-src-0.2.5.tar.gz 1767828 SHA256 49294affa1a43dbd169c0f983575b4ed4b15e02079740115bd4c9cf9401c8793 SHA512 1e853ff957b888d706a4d264aac4573cf4aced02604e2679d5871f3a92c016136a7fb73adf5d5c0be0cea9f28b4bc6faf11abc0334fe2f96a251a7d9cc228711 WHIRLPOOL 150906b115fa76e0837422d5b139721a072e6ccfda376a9958bc8c7731cdb2c4142fedadd2148bd4cfc35314c8177b34c32819b7716ba212544f4c84543669f1
diff --git a/dev-java/jvyamlb/jvyamlb-0.2.5.ebuild b/dev-java/jvyamlb/jvyamlb-0.2.5.ebuild
new file mode 100644
index 000000000000..79e5e8d5410d
--- /dev/null
+++ b/dev-java/jvyamlb/jvyamlb-0.2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JvYAMLb, YAML processor extracted from JRuby"
+HOMEPAGE="http://code.google.com/p/jvyamlb/"
+SRC_URI="http://jvyamlb.googlecode.com/files/jvyamlb-src-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/bytelist:0
+ dev-java/jcodings:0
+ dev-java/joda-time:0"
+
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="bytelist jcodings joda-time"
+
+java_prepare() {
+ rm -fv lib/*.jar || die
+
+ # Don't do tests unnecessarily.
+ sed -i 's:depends="test":depends="compile":' build.xml
+}
+
+src_install() {
+ java-pkg_newjar lib/${P}.jar
+ use source && java-pkg_dosrc src/*
+ dodoc CREDITS README || die
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
diff --git a/dev-java/jvyamlb/metadata.xml b/dev-java/jvyamlb/metadata.xml
new file mode 100644
index 000000000000..46ab2b1323bf
--- /dev/null
+++ b/dev-java/jvyamlb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">jvyamlb</remote-id>
+ </upstream>
+</pkgmetadata>