summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-11-15 10:22:59 -0700
committerSam James <sam@gentoo.org>2023-11-19 18:32:39 +0000
commitbc26dc90eb189ca9e0b637325ede65cc915589d2 (patch)
tree8fd449ea58380762f55c81089d8befd7ea899d7f /dev-haskell
parentdev-haskell/hedgehog: Loosen constraint on template-haskell (diff)
downloadgentoo-bc26dc90eb189ca9e0b637325ede65cc915589d2.tar.gz
gentoo-bc26dc90eb189ca9e0b637325ede65cc915589d2.tar.bz2
gentoo-bc26dc90eb189ca9e0b637325ede65cc915589d2.zip
dev-haskell/bsb-http-chunked: Add conditional upper bound to ghc dep
Tests included with bsb-http-chunked-0.0.0.4 do not work with >=ghc-9.2. Add an upper bound for dev-lang/ghc if USE=test is enabled. Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild2
-rw-r--r--dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild8
2 files changed, 9 insertions, 1 deletions
diff --git a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
index b6272269df21..6513ce234259 100644
--- a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
+++ b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
@@ -11,7 +11,7 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Chunked HTTP transfer encoding for bytestring builders"
-HOMEPAGE="https://github.com/sjakobi/bsb-https-chunked"
+HOMEPAGE="https://github.com/sjakobi/bsb-http-chunked"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild
index 934de12c6e19..5dd3456be0d4 100644
--- a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild
+++ b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4.ebuild
@@ -19,6 +19,14 @@ IUSE=""
RDEPEND=">=dev-lang/ghc-7.10.1:=
"
+
+# Tests do not work correctly on >=ghc-9.2
+RDEPEND+="
+ test? (
+ <dev-lang/ghc-9.1
+ )
+"
+
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.22.2.0
test? ( dev-haskell/attoparsec