summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 08:42:13 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:56 +0000
commit2c204c0657c9482950b0a5a88d858ac370f843bf (patch)
tree6f081e76d7922154ebb40e7c2f91efa1e1cb6175 /dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
parentdev-haskell/text-show: new package, a depend of dev-haskell/persistent-2.6 (diff)
downloadgentoo-2c204c0657c9482950b0a5a88d858ac370f843bf.tar.gz
gentoo-2c204c0657c9482950b0a5a88d858ac370f843bf.tar.bz2
gentoo-2c204c0657c9482950b0a5a88d858ac370f843bf.zip
dev-haskell/quickcheck: bump up to 2.9.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.9.2.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
new file mode 100644
index 000000000000..5d9d16067682
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="+template_haskell"
+
+RESTRICT=test # to avoid test circular depends
+
+RDEPEND=">=dev-haskell/nats-1:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/semigroups-0.9:=[profile?]
+ >=dev-haskell/tf-random-0.4:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( template_haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ $(cabal_flag template_haskell templatehaskell)
+}