summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:14 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:59 +0100
commit0bd72303452e8fa01c625849c6a8e3b3fb913bbc (patch)
tree044f87022705ff56336d2a7ccdd3eeb5667748af /dev-haskell/quickcheck-classes
parentdev-haskell/profunctors: Hackage revision bump (diff)
downloadgentoo-0bd72303452e8fa01c625849c6a8e3b3fb913bbc.tar.gz
gentoo-0bd72303452e8fa01c625849c6a8e3b3fb913bbc.tar.bz2
gentoo-0bd72303452e8fa01c625849c6a8e3b3fb913bbc.zip
dev-haskell/quickcheck-classes: add 0.6.5.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/quickcheck-classes')
-rw-r--r--dev-haskell/quickcheck-classes/Manifest1
-rw-r--r--dev-haskell/quickcheck-classes/metadata.xml43
-rw-r--r--dev-haskell/quickcheck-classes/quickcheck-classes-0.6.5.0.ebuild47
3 files changed, 54 insertions, 37 deletions
diff --git a/dev-haskell/quickcheck-classes/Manifest b/dev-haskell/quickcheck-classes/Manifest
index c6932af438a5..7ff6ea58d8da 100644
--- a/dev-haskell/quickcheck-classes/Manifest
+++ b/dev-haskell/quickcheck-classes/Manifest
@@ -1 +1,2 @@
DIST quickcheck-classes-0.6.4.0.tar.gz 19976 BLAKE2B 614ebc6e1be382a942a55a039921021fd4bcaa2f5c977a8d83bd7b1fb76feebb31f94da908c2389d5f9ab5f7e2481f76223375db41d12b3583658d5d7361ed9b SHA512 2d5786d3cd386a795d5e1ca58ef55fb2efb9285724cf8cbb2f28577973ac2b2a9058ba6185904bc29da88f6d080f4a38629df272502796a0c2e31f9a0e8b658c
+DIST quickcheck-classes-0.6.5.0.tar.gz 20242 BLAKE2B 6b058b9991ad60bc7f9409d9b85d6f02236174eb39765cad3ced0b633ba1877a2866cccd36968e6902e8bae2b2382c319075ce71922afbc1a9e01a6563378b28 SHA512 d0f894d0357522f59440bd795746b3c17802332e3833982cf1d2d20c2a5dc3e4ac1e54f6b3aeac93c0a1beed9f0f4838e20d8798d99bf161b49fc50bdf1f0670
diff --git a/dev-haskell/quickcheck-classes/metadata.xml b/dev-haskell/quickcheck-classes/metadata.xml
index 5f5d00f85a27..1e70ae5d8016 100644
--- a/dev-haskell/quickcheck-classes/metadata.xml
+++ b/dev-haskell/quickcheck-classes/metadata.xml
@@ -6,42 +6,11 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="aeson">
- Enable the use of the `aeson` package. This may be useful for
- accelerating builds in sandboxes for expert users.
- </flag>
- <flag name="semigroupoids">
- Enable the use of the `semigroupoids` package. This may be
- useful for accelerating builds in sandboxes for expert users.
- </flag>
- <flag name="semirings">
- Enable the use of the `semirings` package. This may be useful
- for accelerating builds in sandboxes for expert users.
- </flag>
- <flag name="vector">
- Enable the use of the `vector` package. This may be useful
- for accelerating builds in sandboxes for expert users.
- </flag>
- <flag name="unary-laws">
- Include infrastructure for testing class laws of unary type constructors.
- </flag>
- <flag name="binary-laws">
- Include infrastructure for testing class laws of binary type constructors.
- Disabling `unary-laws` while keeping `binary-laws` enabled is an unsupported
- configuration.
- </flag>
+ <flag name="aeson">You can disable the use of the `aeson` package using `-f-aeson`. This may be useful for accelerating builds in sandboxes for expert users.</flag>
+ <flag name="binary-laws">Include infrastructure for testing class laws of binary type constructors. It is required that this flag match the value that the `unary-laws` flag was given when building `quickcheck-classes-base`. Disabling `unary-laws` while keeping `binary-laws` enabled is an unsupported configuration.</flag>
+ <flag name="semigroupoids">You can disable the use of the `semigroupoids` package using `-f-semigroupoids`. This may be useful for accelerating builds in sandboxes for expert users.</flag>
+ <flag name="semirings">You can disable the use of the `semirings` package using `-f-semirings`. This may be useful for accelerating builds in sandboxes for expert users.</flag>
+ <flag name="unary-laws">Include infrastructure for testing class laws of unary type constructors. It is required that this flag match the value that the `unary-laws` flag was given when building `quickcheck-classes-base`.</flag>
+ <flag name="vector">You can disable the use of the `vector` package using `-f-vector`. This may be useful for accelerating builds in sandboxes for expert users.</flag>
</use>
- <longdescription>
- This library provides QuickCheck properties to ensure
- that typeclass instances adhere to the set of laws that
- they are supposed to. There are other libraries that do
- similar things, such as `genvalidity-hspec` and `checkers`.
- This library differs from other solutions by not introducing
- any new typeclasses that the user needs to learn.
-
- /Note:/ on GHC &lt; 8.5, this library uses the higher-kinded typeclasses
- ('Data.Functor.Classes.Show1', 'Data.Functor.Classes.Eq1', 'Data.Functor.Classes.Ord1', etc.),
- but on GHC &gt;= 8.5, it uses `-XQuantifiedConstraints` to express these
- constraints more cleanly.
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.5.0.ebuild b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.5.0.ebuild
new file mode 100644
index 000000000000..fdc67db7f9e5
--- /dev/null
+++ b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck common typeclasses"
+HOMEPAGE="https://github.com/andrewthad/quickcheck-classes#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+aeson +binary-laws +semigroupoids +semirings +unary-laws +vector"
+
+RDEPEND=">=dev-haskell/primitive-0.6.4:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/primitive-addr-0.1.0.2:=[profile?] <dev-haskell/primitive-addr-0.2:=[profile?]
+ >=dev-haskell/quickcheck-classes-base-0.6.2:=[profile?] <dev-haskell/quickcheck-classes-base-0.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ aeson? ( >=dev-haskell/aeson-0.9:=[profile?] )
+ binary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ semigroupoids? ( dev-haskell/semigroupoids:=[profile?] )
+ semirings? ( >=dev-haskell/semirings-0.4.2:=[profile?] )
+ unary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ !unary-laws? ( !binary-laws? ( >=dev-haskell/quickcheck-2.7:2=[profile?] ) )
+ vector? ( >=dev-haskell/vector-0.12:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+ test? ( >=dev-haskell/base-orphans-0.5
+ dev-haskell/tagged
+ !vector? ( dev-haskell/vector ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag aeson aeson) \
+ $(cabal_flag binary-laws binary-laws) \
+ $(cabal_flag semigroupoids semigroupoids) \
+ $(cabal_flag semirings semirings) \
+ $(cabal_flag unary-laws unary-laws) \
+ $(cabal_flag vector vector)
+}