summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/mmap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/mmap')
-rw-r--r--dev-haskell/mmap/Manifest2
-rw-r--r--dev-haskell/mmap/metadata.xml12
-rw-r--r--dev-haskell/mmap/mmap-0.5.8.ebuild44
-rw-r--r--dev-haskell/mmap/mmap-0.5.9.ebuild44
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-haskell/mmap/Manifest b/dev-haskell/mmap/Manifest
new file mode 100644
index 000000000000..557dc8838c38
--- /dev/null
+++ b/dev-haskell/mmap/Manifest
@@ -0,0 +1,2 @@
+DIST mmap-0.5.8.tar.gz 11657 SHA256 fed460c4ded1953f027fccf705c7c09bc0a8e94bb14b024391387beb4b5afa9f SHA512 6c8b526ec9fedba195ce021f86eeb3fa35f7c95b9299d17503ad7d7e91b9485b3d9980e0ccbdc3876ec465ec8aa07cf9d0521c62e2c8a652a36df11b9badffb5 WHIRLPOOL 02f242eed1e92df8abdcd5488df2b624cdc2794306f741a4f9bbb80b5d5fadc940c7470e042aef43c19fe6781cc5304ccc068e187dee2ac2448f4512a3144be4
+DIST mmap-0.5.9.tar.gz 11731 SHA256 58fcbb04e1cb8e7c36c05823b02dce2faaa989c53d745a7f36192de2fc98b5f8 SHA512 3b9ac1150050ac9d8e7870610923c8303b5fc74a4fdd796d7b6b411e2ba836111ae8520e16ad345aaf93b4dbcd27abd4c359a89b27d854db8dbd252b90a5298d WHIRLPOOL 5bfe1770f0be704ce0c9b00bb99eccc22388c82ab94ddade673f438c17080b533e1130d140d42f8345c48b7a4f403d83b14d1e818c301e80dd9e87b1d6e16780
diff --git a/dev-haskell/mmap/metadata.xml b/dev-haskell/mmap/metadata.xml
new file mode 100644
index 000000000000..750d696bf7ac
--- /dev/null
+++ b/dev-haskell/mmap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides a wrapper to mmap(2) or MapViewOfFile,
+ allowing files or devices to be lazily loaded into memory as
+ strict or lazy ByteStrings, ForeignPtrs or plain Ptrs, using
+ the virtual memory subsystem to do on-demand loading.
+ Modifications are also supported.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mmap/mmap-0.5.8.ebuild b/dev-haskell/mmap/mmap-0.5.8.ebuild
new file mode 100644
index 000000000000..8d9411e062b2
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}
diff --git a/dev-haskell/mmap/mmap-0.5.9.ebuild b/dev-haskell/mmap/mmap-0.5.9.ebuild
new file mode 100644
index 000000000000..98191f67adb1
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}