summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/lens
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/lens')
-rw-r--r--dev-haskell/lens/lens-3.10.0.1.ebuild4
-rw-r--r--dev-haskell/lens/lens-3.9.2.ebuild4
-rw-r--r--dev-haskell/lens/lens-4.11.ebuild4
-rw-r--r--dev-haskell/lens/lens-4.14.ebuild4
-rw-r--r--dev-haskell/lens/lens-4.2.ebuild4
-rw-r--r--dev-haskell/lens/lens-4.6.0.1.ebuild4
-rw-r--r--dev-haskell/lens/lens-4.9.1.ebuild4
7 files changed, 14 insertions, 14 deletions
diff --git a/dev-haskell/lens/lens-3.10.0.1.ebuild b/dev-haskell/lens/lens-3.10.0.1.ebuild
index 263f83cb35a8..eef1125fc918 100644
--- a/dev-haskell/lens/lens-3.10.0.1.ebuild
+++ b/dev-haskell/lens/lens-3.10.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-3.9.2.ebuild b/dev-haskell/lens/lens-3.9.2.ebuild
index 57388654399b..55dade3d7877 100644
--- a/dev-haskell/lens/lens-3.9.2.ebuild
+++ b/dev-haskell/lens/lens-3.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-4.11.ebuild b/dev-haskell/lens/lens-4.11.ebuild
index d2414e10eb74..3b69a8486295 100644
--- a/dev-haskell/lens/lens-4.11.ebuild
+++ b/dev-haskell/lens/lens-4.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-4.14.ebuild b/dev-haskell/lens/lens-4.14.ebuild
index 3fb375841c7e..9fb4d2b39e88 100644
--- a/dev-haskell/lens/lens-4.14.ebuild
+++ b/dev-haskell/lens/lens-4.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-4.2.ebuild b/dev-haskell/lens/lens-4.2.ebuild
index c2a3203cf23b..fbc32e782f63 100644
--- a/dev-haskell/lens/lens-4.2.ebuild
+++ b/dev-haskell/lens/lens-4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-4.6.0.1.ebuild b/dev-haskell/lens/lens-4.6.0.1.ebuild
index 98e7d18bcc97..7bb480c4d471 100644
--- a/dev-haskell/lens/lens-4.6.0.1.ebuild
+++ b/dev-haskell/lens/lens-4.6.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/lens/lens-4.9.1.ebuild b/dev-haskell/lens/lens-4.9.1.ebuild
index fcb962375b77..82ced8d8e4d3 100644
--- a/dev-haskell/lens/lens-4.9.1.ebuild
+++ b/dev-haskell/lens/lens-4.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Lenses, Folds and Traversals"
HOMEPAGE="https://github.com/ekmett/lens/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"