summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-haskell/lens
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/lens')
-rw-r--r--dev-haskell/lens/lens-3.10.0.1.ebuild1
-rw-r--r--dev-haskell/lens/lens-3.9.2.ebuild1
-rw-r--r--dev-haskell/lens/lens-4.11.ebuild1
-rw-r--r--dev-haskell/lens/lens-4.14.ebuild1
-rw-r--r--dev-haskell/lens/lens-4.6.0.1.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-haskell/lens/lens-3.10.0.1.ebuild b/dev-haskell/lens/lens-3.10.0.1.ebuild
index eef1125fc918..609f9849d663 100644
--- a/dev-haskell/lens/lens-3.10.0.1.ebuild
+++ b/dev-haskell/lens/lens-3.10.0.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="benchmark-uniplate dump-splices +inlining lib-werror old-inline-pragmas safe +test-doctests +test-hunit +test-properties +trustworthy"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/bifunctors-4:=[profile?] <dev-haskell/bifunctors-5:=[profile?]
>=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]
diff --git a/dev-haskell/lens/lens-3.9.2.ebuild b/dev-haskell/lens/lens-3.9.2.ebuild
index 55dade3d7877..e94fe831a83e 100644
--- a/dev-haskell/lens/lens-3.9.2.ebuild
+++ b/dev-haskell/lens/lens-3.9.2.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="benchmark-uniplate dump-splices +inlining lib-werror old-inline-pragmas safe +test-doctests +test-hunit +test-properties +trustworthy"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/bifunctors-3:=[profile?] <dev-haskell/bifunctors-4:=[profile?]
>=dev-haskell/comonad-3:=[profile?] <dev-haskell/comonad-4:=[profile?]
diff --git a/dev-haskell/lens/lens-4.11.ebuild b/dev-haskell/lens/lens-4.11.ebuild
index 3b69a8486295..52018405253d 100644
--- a/dev-haskell/lens/lens-4.11.ebuild
+++ b/dev-haskell/lens/lens-4.11.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE="benchmark-uniplate dump-splices +inlining j old-inline-pragmas safe +test-doctests +test-hlint +test-hunit +test-properties +trustworthy"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/bifunctors-5:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
>=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]
diff --git a/dev-haskell/lens/lens-4.14.ebuild b/dev-haskell/lens/lens-4.14.ebuild
index 9fb4d2b39e88..5cd6d4e13869 100644
--- a/dev-haskell/lens/lens-4.14.ebuild
+++ b/dev-haskell/lens/lens-4.14.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE="benchmark-uniplate dump-splices +inlining j old-inline-pragmas safe +test-doctests +test-templates +trustworthy"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
>=dev-haskell/bifunctors-5:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
diff --git a/dev-haskell/lens/lens-4.6.0.1.ebuild b/dev-haskell/lens/lens-4.6.0.1.ebuild
index 7bb480c4d471..65c51397c391 100644
--- a/dev-haskell/lens/lens-4.6.0.1.ebuild
+++ b/dev-haskell/lens/lens-4.6.0.1.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
IUSE="benchmark-uniplate dump-splices +inlining j old-inline-pragmas safe +test-doctests +test-hlint +test-hunit +test-properties +trustworthy"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-haskell/bifunctors-4:=[profile?] <dev-haskell/bifunctors-5:=[profile?]
>=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]