summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:03 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:44 +0100
commit853085f6ade3cc0bd9975e6cf1af003d8065e439 (patch)
treeb2d30a32b9e2876b2da26c0c0d7bfcc8dfef04d3 /dev-haskell/hsyaml
parentdev-haskell/microaeson: new package, add 0.1.0.1 (diff)
downloadgentoo-853085f6ade3cc0bd9975e6cf1af003d8065e439.tar.gz
gentoo-853085f6ade3cc0bd9975e6cf1af003d8065e439.tar.bz2
gentoo-853085f6ade3cc0bd9975e6cf1af003d8065e439.zip
dev-haskell/hsyaml: add 0.2.1.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hsyaml')
-rw-r--r--dev-haskell/hsyaml/Manifest1
-rw-r--r--dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild37
-rw-r--r--dev-haskell/hsyaml/metadata.xml20
3 files changed, 45 insertions, 13 deletions
diff --git a/dev-haskell/hsyaml/Manifest b/dev-haskell/hsyaml/Manifest
index 68e65ca3a7fd..e9d179396612 100644
--- a/dev-haskell/hsyaml/Manifest
+++ b/dev-haskell/hsyaml/Manifest
@@ -1 +1,2 @@
DIST HsYAML-0.2.1.0.tar.gz 83976 BLAKE2B fff32d30eb6cb76c852c9cb1909b8be06e4818d23322397271594dfe60895ea79ffa8cc4c4944173de30d46e1ef8a2872972434aeacec44fff8d52dc169264e5 SHA512 f8ad41a99e48183835093ad8bf6a3fbdf4b9ad9df3bea46b12efd55a9555c22bd2595c72b1ac2e73379ab47e21f6cbf9022412db8971e1c7c02a32e824f53304
+DIST hsyaml-0.2.1.2.tar.gz 84263 BLAKE2B 1fb534a31cdcc41536e3f0114f27b4f140142293aca052d72d5d5993ff5ff686fea30a893e30efe34c2969ad9237228a43960f8adac201470568628d60464237 SHA512 4ade814924422a0985096be48ce0305f8491df03985511b408fefcf68a044f9ec4a0d29d978c2bb72b36315c49ee3faea69d8336cd5d88ca3d2d86077f46d003
diff --git a/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild b/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild
new file mode 100644
index 000000000000..162f34b60644
--- /dev/null
+++ b/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_PN="HsYAML"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure Haskell YAML 1.2 processor"
+HOMEPAGE="https://github.com/haskell-hvr/HsYAML"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="exe"
+
+RDEPEND=">=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-2.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ exe? ( >=dev-haskell/megaparsec-7.0:=[profile?] <dev-haskell/megaparsec-10:=[profile?]
+ >=dev-haskell/microaeson-0.1:=[profile?] <dev-haskell/microaeson-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/quickcheck-2.14 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.6
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag exe exe)
+}
diff --git a/dev-haskell/hsyaml/metadata.xml b/dev-haskell/hsyaml/metadata.xml
index 298c3553c5d9..b11316eec0dc 100644
--- a/dev-haskell/hsyaml/metadata.xml
+++ b/dev-haskell/hsyaml/metadata.xml
@@ -5,17 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @HsYAML@ is a [YAML 1.2](http://yaml.org/spec/1.2/spec.html) parser implementation for Haskell.
-
- Features of @HsYAML@ include:
-
- * Pure Haskell implementation with small dependency footprint and emphasis on strict compliance with the [YAML 1.2 specification](http://yaml.org/spec/1.2/spec.html).
- * Direct decoding to native Haskell types via (@aeson@-inspired) typeclass-based API (see "Data.YAML").
- * Support for constructing custom YAML node graph representation (including support for cyclic YAML data structures).
- * Support for the standard (untyped) /Failsafe/, (strict) /JSON/, and (flexible) /Core/ \"schemas\" providing implicit typing rules as defined in the YAML 1.2 specification (including support for user-defined custom schemas).
- * Event-based API resembling LibYAML's Event-based API (see "Data.YAML.Event").
- * Low-level API access to lexical token-based scanner (see "Data.YAML.Token").
-
- </longdescription>
+ <use>
+ <flag name="exe">Enable @exe:yaml-test@ component</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">HsYAML</remote-id>
+ <remote-id type="github">haskell-hvr/HsYAML</remote-id>
+ </upstream>
</pkgmetadata>