summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 20:46:30 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:14 +0000
commite507323bb599a0b439e2838b8c5c1bda779105df (patch)
treeb00e8c1c72b7627bf7f0e6125519a96d9a859635 /dev-haskell/hslua-core
parentdev-haskell/hslua-core: new package, add 2.2.0 (diff)
downloadgentoo-e507323bb599a0b439e2838b8c5c1bda779105df.tar.gz
gentoo-e507323bb599a0b439e2838b8c5c1bda779105df.tar.bz2
gentoo-e507323bb599a0b439e2838b8c5c1bda779105df.zip
dev-haskell/hslua-core: add 2.1.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hslua-core')
-rw-r--r--dev-haskell/hslua-core/Manifest1
-rw-r--r--dev-haskell/hslua-core/hslua-core-2.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/hslua-core/Manifest b/dev-haskell/hslua-core/Manifest
index 04fd7fc31e9f..f1f4de6908e8 100644
--- a/dev-haskell/hslua-core/Manifest
+++ b/dev-haskell/hslua-core/Manifest
@@ -1 +1,2 @@
+DIST hslua-core-2.1.0.tar.gz 36047 BLAKE2B df175f92df38d4b7ab4810eabef30c9f89479f905fd586cc85c124ef19896dca0532938012c7c55186cfad2d0e057f632f75a967420c2fdc22c57816731dd2f1 SHA512 7a92937f129125b58c0534d2c2b3b2f1798d6a24326ae6a6ef97d93630d9fb53604ead4d9bce23d1f0d3cb7fca4f716284619b651ee3bbdab71619edb30249c0
DIST hslua-core-2.2.0.tar.gz 36808 BLAKE2B 02cbb94ea562fbaac9c2eb9445150f6f79a345ab15b2062aa7900d18c671ad0104a0ad3abe6603a38ddb40a9fa59cd13f4892d73c7dba4baff5727a9211fa503 SHA512 cb2f8b76b44432698624aac3d425be7a0c068bec1d41cd8a13b75854ed15fc614de5a0aee46c1092ef22b0e6b706a931188879d97354c01c37aa47a334baf5f3
diff --git a/dev-haskell/hslua-core/hslua-core-2.1.0.ebuild b/dev-haskell/hslua-core/hslua-core-2.1.0.ebuild
new file mode 100644
index 000000000000..53071a64e051
--- /dev/null
+++ b/dev-haskell/hslua-core/hslua-core-2.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to Lua, an embeddable scripting language"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.2:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"