summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 10:36:14 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:03 -0500
commitf768adb9033809ef185f5b5961c3e2bd23f50ae9 (patch)
tree52d0b977ea165665ba0be02c1c535e93c7bbe98e /dev-gap/ctbllib
parentdev-gap/resclasses: new package, add 4.7.3 (diff)
downloadgentoo-f768adb9033809ef185f5b5961c3e2bd23f50ae9.tar.gz
gentoo-f768adb9033809ef185f5b5961c3e2bd23f50ae9.tar.bz2
gentoo-f768adb9033809ef185f5b5961c3e2bd23f50ae9.zip
dev-gap/ctbllib: new package, add 1.3.6
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/ctbllib')
-rw-r--r--dev-gap/ctbllib/Manifest1
-rw-r--r--dev-gap/ctbllib/ctbllib-1.3.6.ebuild62
-rw-r--r--dev-gap/ctbllib/metadata.xml19
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-gap/ctbllib/Manifest b/dev-gap/ctbllib/Manifest
new file mode 100644
index 000000000000..635e5f86bc11
--- /dev/null
+++ b/dev-gap/ctbllib/Manifest
@@ -0,0 +1 @@
+DIST ctbllib-1.3.6.tar.gz 16603964 BLAKE2B 3994c4e100bcce46b5cbe7d34d6bad310b950495607fc11fe0dabb9d72767fea38ad2a5bce633393c4df78b5dd039257fccf83fcb208eaec458e5872b363ca00 SHA512 ac4ab422bc861816363623f19cc72aa23490198192e39ddcc4b407790504a8e316c21b580217e6b4ec5f956ccf784a2b118848d11e0d9fd2efb528424349ba26
diff --git a/dev-gap/ctbllib/ctbllib-1.3.6.ebuild b/dev-gap/ctbllib/ctbllib-1.3.6.ebuild
new file mode 100644
index 000000000000..dd817df9621f
--- /dev/null
+++ b/dev-gap/ctbllib/ctbllib-1.3.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="The GAP Character Table Library"
+SLOT="0"
+SRC_URI="https://www.math.rwth-aachen.de/~Thomas.Breuer/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+#IUSE="test"
+RESTRICT=test
+
+RDEPEND="dev-gap/atlasrep"
+#BDEPEND="test? (
+# dev-gap/browse
+# dev-gap/spinsym
+# dev-gap/tomlib
+#)"
+
+# The are "extra" docs and not the HTML produced by GAPDoc. The glob
+# gets expanded if we use a plain variable but not if we use a bash
+# array.
+HTML_DOCS="htm/*"
+
+GAP_PKG_EXTRA_INSTALL=( ctbltoc data dlnames doc2 gap4 )
+
+gap-pkg_enable_tests
+
+src_install() {
+ gap-pkg_src_install
+
+ # This package has a "doc2" directory that contains an entirely
+ # separate set of GAPDoc documentation called "CTblLibXpls." They
+ # are mentioned in PackageInfo.g. On the assumption that "Xpls"
+ # stands for "examples," we install it (unconditionally, and via
+ # symlink) as "examples" by copying most of the GAPDoc installation
+ # bits from gap-pkg_src_install().
+ pushd doc2 > /dev/null || die
+
+ local docdir="$(gap-pkg_dir)/doc2"
+ insinto "${docdir}"
+
+ for f in *.{lab,six,txt,xml}; do
+ doins "${f}"
+ done
+
+ for f in *.pdf; do
+ doins "${f}"
+ dosym -r "${docdir}/${f}" "/usr/share/doc/${PF}/examples/${f}"
+ done
+
+ for f in *.{html,css,js,png}; do
+ doins "${f}"
+ dosym -r "${docdir}/${f}" "/usr/share/doc/${PF}/examples/html/${f}"
+ done
+
+ popd > /dev/null || die
+}
diff --git a/dev-gap/ctbllib/metadata.xml b/dev-gap/ctbllib/metadata.xml
new file mode 100644
index 000000000000..df52135df9e1
--- /dev/null
+++ b/dev-gap/ctbllib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+</pkgmetadata>