summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-11 19:56:33 +0100
committerSam James <sam@gentoo.org>2024-06-11 19:57:29 +0100
commitf0c447abf681cf8b7f99b84efe8838537915edc7 (patch)
tree36ff765bb84bc063849a0fc7ec82d5b5fd271fd8 /dev-debug
parentdev-php/PEAR-Auth_SASL: add 1.2.0 (diff)
downloadgentoo-f0c447abf681cf8b7f99b84efe8838537915edc7.tar.gz
gentoo-f0c447abf681cf8b7f99b84efe8838537915edc7.tar.bz2
gentoo-f0c447abf681cf8b7f99b84efe8838537915edc7.zip
dev-debug/valgrind: backport patches from stable branch for 3.23.0
Per https://sourceforge.net/p/valgrind/mailman/message/58782511/. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/valgrind/Manifest1
-rw-r--r--dev-debug/valgrind/valgrind-3.23.0_p1.ebuild193
-rw-r--r--dev-debug/valgrind/valgrind-9999.ebuild30
3 files changed, 221 insertions, 3 deletions
diff --git a/dev-debug/valgrind/Manifest b/dev-debug/valgrind/Manifest
index 21a5e4c20e6d..441394c4aa5a 100644
--- a/dev-debug/valgrind/Manifest
+++ b/dev-debug/valgrind/Manifest
@@ -2,5 +2,6 @@ DIST valgrind-3.21.0.tar.bz2 17449484 BLAKE2B 1f7306d288eb5ecfb2b2f0b2dc68960ecd
DIST valgrind-3.21.0.tar.bz2.asc 488 BLAKE2B 6297bc925c16526a51de4f589232a8d5bcb8d54bdc885c145d329deeba45b42d3a5a8a3f59d3fb240d3bd78be7fd30d95ceb33c7624afd3c99c51833d0fd16f2 SHA512 114e5cd2f7352e56099efa3b2c42d39ed24e42419bbaac1af5e2b5c4fa72a2ba38ac6b0c60b93460a0cce8819ca0c7fae6618599b2af809ac0ab4fa30fdb25ba
DIST valgrind-3.22.0.tar.bz2 16565502 BLAKE2B 80024371b3e70521996077fba24e233097a6190477ced1b311cd41fead687dcc2511ac0ef723792488f4af08867dff3e1f474816fda09c1604b89059e31c2514 SHA512 2904c13f68245bbafcea70998c6bd20725271300a7e94b6751ca00916943595fc3fac8557da7ea8db31b54a43f092823a0a947bc142829da811d074e1fe49777
DIST valgrind-3.22.0.tar.bz2.asc 488 BLAKE2B 9e4d4cfac4dcc09bb62beeaa7b9f78bfafd0a6ae8d63e423ff81b7b8f5444a301e4c3030a241644c8070c36ee040832ce99f444678f22611457e325ceae18dd1 SHA512 c2317db564ef816d2b5d1a7f2f680dc1c6ea05abbffde660587946c986af179ea7ca2314d94c792f63f3043b6a44819ddf5661fd60ec2454a2c562e7d2711b36
+DIST valgrind-3.23.0-patches-1.tar.xz 9660 BLAKE2B 0f59ff11d440cf39c3af6a3c6d9a21b0d922f79cb00e77c0e183224e4baca6037d30c48368934498ee5bf5c98b555b2cf80d0bdcef851f264949199079c74f65 SHA512 69544e36f0d3718c02ca781b58c5f76856ccba3a863cee785342e26265a430b2b5aebd1e558dd63ba798cc762be750ac66f192ef4eeb3bc18c6c156633475683
DIST valgrind-3.23.0.tar.bz2 16550038 BLAKE2B 9312761b0531006725f13270984b26c48f71ebe66e355b04410d7c01773c9b78ec21db3259cab398e58b3b68f93f5f074db06efe1f359bd7cf423515576191a4 SHA512 27d038faaaf6154cace2df18c3573291393548ba0738dbb6aba58eab6324c5beaa95fc5f3c0271663ca071baf829b15d806f7e81074f7cf087bef20ea0ed3117
DIST valgrind-3.23.0.tar.bz2.asc 488 BLAKE2B b06781577e3e84e506e56bd4acc7341aecacb6b5898d8f0daab627d24bc70c9c60edad11dc7e3723ac77aa9c7978f1e13af7734e7a37763c720e77ea4ff103a4 SHA512 e10b38c72ed1fb8d79a3fa84ab70c475ec7a15927a578ee6715aa74f9600453f0fb72551053b6c31583321c37dab100bafbf6e689c02a3bc06021f6092b4bc80
diff --git a/dev-debug/valgrind/valgrind-3.23.0_p1.ebuild b/dev-debug/valgrind/valgrind-3.23.0_p1.ebuild
new file mode 100644
index 000000000000..b19c8e416302
--- /dev/null
+++ b/dev-debug/valgrind/valgrind-3.23.0_p1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The Valgrind upstream maintainer also maintains it in Fedora and will
+# backport fixes there which haven't yet made it into a release. Keep an eye
+# on it for fixes we should cherry-pick too:
+# https://src.fedoraproject.org/rpms/valgrind/tree/rawhide
+#
+# Also check the ${PV}_STABLE branch upstream for backports.
+
+inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="https://valgrind.org"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/valgrind.gpg
+ inherit verify-sig
+
+ MY_P="${P/_rc/.RC}"
+ MY_P="${MY_P%%_p*}"
+ VALGRIND_PATCH_TARBALL="${MY_P}-patches-1"
+ SRC_URI="
+ https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2
+ verify-sig? ( https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2.asc )
+ "
+ # Rollups of backports on ${PV}_STABLE branch upstream.
+ if [[ ${PV} == *_p* ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${VALGRIND_PATCH_TARBALL}.tar.xz"
+ fi
+
+ S="${WORKDIR}"/${MY_P}
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ fi
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == 9999 ]] ; then
+ # Needed for man pages
+ BDEPEND+="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ "
+else
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-valgrind )"
+fi
+
+PATCHES=(
+ # Respect CFLAGS, LDFLAGS
+ "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+ "${FILESDIR}"/${PN}-3.21.0-glibc-2.34-suppressions.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # "checking if gcc accepts nested functions" but clang cannot handle good
+ # errors and reports both "function definition is not allowed here" and
+ # -Wimplicit-function-declaration. bug #900396
+ foo
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ elif use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.bz2{,.asc}
+ fi
+
+ default
+}
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
+ if [[ -d "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} ]] ; then
+ PATCHES+=( "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} )
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-gdbscripts-dir="${EPREFIX}"/usr/share/gdb/auto-load
+ )
+
+ tc-is-lto && myconf+=( --enable-lto )
+
+ # Respect ar, bug #468114
+ tc-export AR
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -fstack-protector-all Fails same way as -fstack-protector/-fstack-protector-strong.
+ # Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+ # -fstack-protector-strong See -fstack-protector (bug #620402)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -fharden-control-flow-redundancy: breaks runtime ('jump to the invalid address stated on the next line')
+ filter-flags -fomit-frame-pointer
+ filter-flags -fstack-protector
+ filter-flags -fstack-protector-all
+ filter-flags -fstack-protector-strong
+ filter-flags -m64 -mx32
+ filter-flags -fsanitize -fsanitize=*
+ filter-flags -fharden-control-flow-redundancy
+ append-cflags $(test-flags-CC -fno-harden-control-flow-redundancy)
+ filter-lto
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x64-macos && myconf+=("--enable-only64bit")
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf+=("--without-mpicc")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # fxsave.o, tronical.o have textrels
+ # -fno-strict-aliasing: https://bugs.kde.org/show_bug.cgi?id=486093
+ emake CFLAGS="${CFLAGS} -fno-strict-aliasing" LDFLAGS="${LDFLAGS} -Wl,-z,notext" check
+}
+
+src_install() {
+ if [[ ${PV} == 9999 ]]; then
+ # TODO: Could do HTML docs too with 'all-docs'
+ emake -C docs man-pages FAQ.txt
+ mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
+ fi
+
+ default
+
+ dodoc FAQ.txt
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ # See README_PACKAGERS
+ dostrip -x /usr/libexec/valgrind/vgpreload* /usr/$(get_libdir)/valgrind/*
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Valgrind will not work if libc (e.g. glibc) does not have debug symbols."
+ elog "To fix this you can add splitdebug to FEATURES in make.conf"
+ elog "and remerge glibc. See:"
+ elog "https://bugs.gentoo.org/214065"
+ elog "https://bugs.gentoo.org/274771"
+ elog "https://bugs.gentoo.org/388703"
+}
diff --git a/dev-debug/valgrind/valgrind-9999.ebuild b/dev-debug/valgrind/valgrind-9999.ebuild
index 48014039f07e..b19c8e416302 100644
--- a/dev-debug/valgrind/valgrind-9999.ebuild
+++ b/dev-debug/valgrind/valgrind-9999.ebuild
@@ -14,6 +14,7 @@ inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
DESCRIPTION="An open-source memory debugger for GNU/Linux"
HOMEPAGE="https://valgrind.org"
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
inherit git-r3
@@ -22,8 +23,17 @@ else
inherit verify-sig
MY_P="${P/_rc/.RC}"
- SRC_URI="https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2"
- SRC_URI+=" verify-sig? ( https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2.asc )"
+ MY_P="${MY_P%%_p*}"
+ VALGRIND_PATCH_TARBALL="${MY_P}-patches-1"
+ SRC_URI="
+ https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2
+ verify-sig? ( https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2.asc )
+ "
+ # Rollups of backports on ${PV}_STABLE branch upstream.
+ if [[ ${PV} == *_p* ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${VALGRIND_PATCH_TARBALL}.tar.xz"
+ fi
+
S="${WORKDIR}"/${MY_P}
if [[ ${PV} != *_rc* ]] ; then
@@ -52,7 +62,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
"${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
"${FILESDIR}"/${PN}-3.21.0-glibc-2.34-suppressions.patch
- # From stable branch
)
QA_CONFIG_IMPL_DECL_SKIP+=(
@@ -62,6 +71,17 @@ QA_CONFIG_IMPL_DECL_SKIP+=(
foo
)
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ elif use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.bz2{,.asc}
+ fi
+
+ default
+}
+
src_prepare() {
# Correct hard coded doc location
sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
@@ -78,6 +98,10 @@ src_prepare() {
cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
fi
+ if [[ -d "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} ]] ; then
+ PATCHES+=( "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} )
+ fi
+
default
eautoreconf