summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-02-18 23:21:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-03-29 09:50:57 +0200
commitb91e3faab0bbb54c22f4289897d5d6ef90a1c590 (patch)
treeb09578e2d088dc9887afebb024b5cb7ecba6c8db /dev-debug
parentdev-debug/pwndbg: enable py3.12 (diff)
downloadgentoo-b91e3faab0bbb54c22f4289897d5d6ef90a1c590.tar.gz
gentoo-b91e3faab0bbb54c22f4289897d5d6ef90a1c590.tar.bz2
gentoo-b91e3faab0bbb54c22f4289897d5d6ef90a1c590.zip
dev-debug/pwndbg: sync live
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/35415 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/pwndbg/pwndbg-99999999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-debug/pwndbg/pwndbg-99999999.ebuild b/dev-debug/pwndbg/pwndbg-99999999.ebuild
index 304326ef2983..660b4d397fec 100644
--- a/dev-debug/pwndbg/pwndbg-99999999.ebuild
+++ b/dev-debug/pwndbg/pwndbg-99999999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=poetry
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 wrapper
@@ -18,7 +18,7 @@ if [[ ${PV} == "99999999" ]]; then
else
MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
SRC_URI="https://github.com/pwndbg/pwndbg/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
@@ -36,12 +36,15 @@ RDEPEND="
>=dev-python/pygments-2.15.1[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
- >=dev-util/pwntools-4.10.0[${PYTHON_USEDEP}]
+ >=dev-util/pwntools-4.11.0[${PYTHON_USEDEP}]
>=dev-util/ROPgadget-7.2[${PYTHON_USEDEP}]
>=dev-util/unicorn-2.0.1[python,${PYTHON_USEDEP}]
')
"
+# Tests are architectur-specific (precompiled binaries)
+RESTRICT="test"
+
src_prepare() {
if [[ ${PV} != 99999999 ]]; then
sed -e "s/__version__ = '\(.*\)'/__version__ = '${PV}'/" \