summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 12:16:58 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 12:19:49 +0100
commite100765f696dbef8f07806185513ec4bf029c9e9 (patch)
treeef13fa9714661cdd18a45083978fe2131ab03b15 /dev-db
parentdev-python/SchemaObject: distutils-r1, EAPI=6, HOMEPAGE (diff)
downloadgentoo-e100765f696dbef8f07806185513ec4bf029c9e9.tar.gz
gentoo-e100765f696dbef8f07806185513ec4bf029c9e9.tar.bz2
gentoo-e100765f696dbef8f07806185513ec4bf029c9e9.zip
dev-db/SchemaSync: distutils-r1, EAPI=6, HOMEPAGE
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/SchemaSync/SchemaSync-0.9.2-r1.ebuild25
-rw-r--r--dev-db/SchemaSync/SchemaSync-0.9.2.ebuild45
2 files changed, 25 insertions, 45 deletions
diff --git a/dev-db/SchemaSync/SchemaSync-0.9.2-r1.ebuild b/dev-db/SchemaSync/SchemaSync-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..f09a656ac426
--- /dev/null
+++ b/dev-db/SchemaSync/SchemaSync-0.9.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="MySQL Schema Versioning and Migration Utility"
+HOMEPAGE="https://github.com/mmatuson/SchemaSync"
+# old download location is down
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ dev-python/SchemaObject[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild b/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild
deleted file mode 100644
index 2769787743be..000000000000
--- a/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-PYTHON_DEPEND="2:2.5:2.7"
-
-inherit distutils
-
-DESCRIPTION="MySQL Schema Versioning and Migration Utility"
-HOMEPAGE="http://schemasync.org/"
-SRC_URI="http://www.schemasync.org/downloads/${P}.tar.gz"
-
-# Switch to ,, when we switch to EAPI=6.
-#pn="${PN,,}"
-pn="schemasync"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-python/setuptools
- dev-python/mysql-python
- dev-python/SchemaObject"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- python_convert_shebangs -r 2 .
-}
-
-pkg_postinst() {
- python_mod_optimize "${pn}"
-}
-
-pkg_postrm() {
- python_mod_cleanup "${pn}"
-}