summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-11-12 11:00:15 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-13 12:17:43 +0200
commitd0123068321625c68be5c1c2a1010408eae388af (patch)
tree7aa83b27f40dc34ab4543c2a7554d14310be8964 /dev-cpp
parentsys-kernel/linux-firmware: Keyword 20231111 x86, #917269 (diff)
downloadgentoo-d0123068321625c68be5c1c2a1010408eae388af.tar.gz
gentoo-d0123068321625c68be5c1c2a1010408eae388af.tar.bz2
gentoo-d0123068321625c68be5c1c2a1010408eae388af.zip
dev-cpp/yaml-cpp: fix test build
Closes: https://bugs.gentoo.org/917243 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/33777 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-gcc13.patch32
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-gcc13.patch b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-gcc13.patch
new file mode 100644
index 000000000000..f024b797eb47
--- /dev/null
+++ b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-gcc13.patch
@@ -0,0 +1,32 @@
+Fix test https://bugs.gentoo.org/917243
+
+From fcbb8193b94921e058be7b563aea053531e5b2d9 Mon Sep 17 00:00:00 2001
+From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Date: Sat, 19 Aug 2023 21:36:16 +0200
+Subject: [PATCH] Fix testsuite with gcc-13 (#1216)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+cd /<<PKGBUILDDIR>>/build-static/test && /usr/bin/c++ -DYAML_CPP_STATIC_DEFINE -I/<<PKGBUILDDIR>>/test/integration -I/<<PKGBUILDDIR>>/test -I/<<PKGBUILDDIR>>/src -I/<<PKGBUILDDIR>>/include -isystem /usr/src/googletest/googlemock/include -isystem /usr/src/googletest/googlemock -isystem /usr/src/googletest/googletest/include -isystem /usr/src/googletest/googletest -g -O2 -ffile-prefix-map=/<<PKGBUILDDIR>>=. -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -fdebug-prefix-map=/<<PKGBUILDDIR>>=/usr/src/yaml-cpp-0.8.0+dfsg-1~build1 -Wdate-time -D_FORTIFY_SOURCE=2 -std=gnu++14 -Wno-variadic-macros -Wno-sign-compare -DGTEST_HAS_PTHREAD=1 -MD -MT test/CMakeFiles/yaml-cpp-tests.dir/binary_test.cpp.o -MF CMakeFiles/yaml-cpp-tests.dir/binary_test.cpp.o.d -o CMakeFiles/yaml-cpp-tests.dir/binary_test.cpp.o -c /<<PKGBUILDDIR>>/test/binary_test.cpp
+/<<PKGBUILDDIR>>/test/binary_test.cpp: In member function ‘virtual void BinaryTest_DecodingNoCrashOnNegative_Test::TestBody()’:
+/<<PKGBUILDDIR>>/test/binary_test.cpp:11:38: error: narrowing conversion of ‘-58’ from ‘int’ to ‘char’ [-Wnarrowing]
+ 11 | std::string input{-58, -1, -99, 109};
+ | ^
+---
+ test/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 351b03f81..c9e7f041b 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -33,7 +33,7 @@ target_include_directories(yaml-cpp-tests
+ target_compile_options(yaml-cpp-tests
+ PRIVATE
+ $<$<CXX_COMPILER_ID:Clang>:-Wno-c99-extensions -Wno-variadic-macros -Wno-sign-compare>
+- $<$<CXX_COMPILER_ID:GNU>:-Wno-variadic-macros -Wno-sign-compare>)
++ $<$<CXX_COMPILER_ID:GNU>:-Wno-variadic-macros -Wno-sign-compare -Wno-narrowing>)
+ target_link_libraries(yaml-cpp-tests
+ PRIVATE
+ Threads::Threads
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
index ec6c6b7a8293..3c11b51f1f10 100644
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
@@ -21,6 +21,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/yaml-cpp-0.8.0-gtest.patch"
+ "${FILESDIR}/yaml-cpp-0.8.0-gcc13.patch"
)
src_configure() {