summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-03-21 21:48:21 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-03-21 21:48:21 +0000
commite1216ad522c5b134dc5d666882af155a46b7e23b (patch)
tree0582c0a134a8ae26d3c341a1e5d914bdc58fc877 /dev-cpp/sdbus-c++
parentdev-util/patchelf: Drop old 0.10 and 0.14.3 (diff)
downloadgentoo-e1216ad522c5b134dc5d666882af155a46b7e23b.tar.gz
gentoo-e1216ad522c5b134dc5d666882af155a46b7e23b.tar.bz2
gentoo-e1216ad522c5b134dc5d666882af155a46b7e23b.zip
dev-cpp/sdbus-c++: Use python-any-r1 eclass to build systemd
Closes: https://bugs.gentoo.org/835705 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp/sdbus-c++')
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild15
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild15
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild
index 2e96c31113c1..04f6c85c5a16 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit meson cmake
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1 meson cmake
SDP="systemd-stable-250.4"
DESCRIPTION="High-level C++ D-Bus library"
@@ -34,12 +35,24 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen[dot] )
+ !systemd? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/jinja[${PYTHON_USEDEP}]')
+ )
"
+python_check_deps() {
+ has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
S="${WORKDIR}/sdbus-cpp-${PV}"
SDS="${WORKDIR}/${SDP}"
SDB="${WORKDIR}/systemd-build"
+pkg_setup() {
+ use systemd || python-any-r1_pkg_setup
+}
+
src_prepare() {
if ! use systemd; then
pushd "${SDS}" || die
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild
index 454cc5196d10..7eee346da844 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit meson cmake
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1 meson cmake
SDP="systemd-stable-250.4"
DESCRIPTION="High-level C++ D-Bus library"
@@ -34,8 +35,16 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen[dot] )
+ !systemd? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/jinja[${PYTHON_USEDEP}]')
+ )
"
+python_check_deps() {
+ has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
S="${WORKDIR}/sdbus-cpp-${PV}"
SDS="${WORKDIR}/${SDP}"
SDB="${WORKDIR}/systemd-build"
@@ -44,6 +53,10 @@ PATCHES=(
"${FILESDIR}"/${PN}-gtest-1.11.patch
)
+pkg_setup() {
+ use systemd || python-any-r1_pkg_setup
+}
+
src_prepare() {
if ! use systemd; then
pushd "${SDS}" || die