summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 06:17:14 +0000
committerSam James <sam@gentoo.org>2023-11-25 06:19:38 +0000
commita316d1d8e85646caa2a8bd8ff5238aacd3123b93 (patch)
tree2c0e53efb7af78c5710313719d9eab49d70befb2 /dev-cpp/folly
parentx11-plugins/gkrellm-vaiobright: drop 2.5-r3 (diff)
downloadgentoo-a316d1d8e85646caa2a8bd8ff5238aacd3123b93.tar.gz
gentoo-a316d1d8e85646caa2a8bd8ff5238aacd3123b93.tar.bz2
gentoo-a316d1d8e85646caa2a8bd8ff5238aacd3123b93.zip
dev-cpp/folly: drop 2023.02.06.00, 2023.05.22.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest2
-rw-r--r--dev-cpp/folly/files/folly-2022.07.04.00-musl-fix.patch36
-rw-r--r--dev-cpp/folly/folly-2023.02.06.00.ebuild105
-rw-r--r--dev-cpp/folly/folly-2023.05.22.00.ebuild90
4 files changed, 0 insertions, 233 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 0f7c876c562f..6516ea9b2298 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,3 +1 @@
-DIST folly-v2023.02.06.00.tar.gz 3790845 BLAKE2B b1c0eed7a2dccba3ccb5e25aa24cc0a6d628fbc3134bf0ed82a1e0e614825a3ae620d79a54e2bea398274afcb662bdfca48d7193f69db35f624ed6a2fa9bae99 SHA512 b9cd8132a702e88e4c9fefcce190d9fd403253c9b71dc22316f237922d99f9cd980ab81d50ddb48ae0e614a493b3d61865b03eee46d59805f83fce528f831646
-DIST folly-v2023.05.22.00.tar.gz 3834791 BLAKE2B e981f844b12620b274a78fa6640d1510525c1b4cc3bb35594bd5c5daf238eb19291a1ddf19f29e26269effbe79c22ccc9c002f5f547e06566aa804f0d92a0a9c SHA512 4af93f23a6835efaca317dc7a15abe13619d498efbaa5b349a30682be35c129bd87ab9723c5186e63e3d3b646a80816b994f5237108f8d489a50a028bb16c9da
DIST folly-v2023.06.19.00.tar.gz 3850872 BLAKE2B 6332b6de28fd4a0c19b20c4b23fa7093bded940fb07de92ad9fa7f44b8347fb5e5543e5a57c32d2414f345b4f7b306eed806c5d48a871a06833c1d2a71a34584 SHA512 9189adddf59019787969c7edb27a3e57436c2dca772f3142cdbf66e3a69b398be7ae4f2c36a9576c7ad9c51fd3703555e2a7ad6ed1ddce4036f8760d8095d371
diff --git a/dev-cpp/folly/files/folly-2022.07.04.00-musl-fix.patch b/dev-cpp/folly/files/folly-2022.07.04.00-musl-fix.patch
deleted file mode 100644
index 001af39625c5..000000000000
--- a/dev-cpp/folly/files/folly-2022.07.04.00-musl-fix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-# Elf.cpp expects __ELF_NATIVE_CLASS to be defined at least for platforms
-# besides FreeBSD-based ones, and so it defines FOLLY_ELF_NATIVE_CLASS with it.
-# Without __ELF_NATIVE_CLASS (and apparently musl does not define it),
-# FOLLY_ELF_NATIVE_CLASS is also not defined so what was supposed to be
-# expanded to ELFCLASS32 or ELFCLASS64 ends up being
-# ELFCLASSFOLLY_ELF_NATIVE_CLASS.
-#
-# Please refer: https://github.com/facebook/folly/issues/1478
-#
-# Closes: https://bugs.gentoo.org/835744
---- a/folly/experimental/symbolizer/Elf.cpp
-+++ b/folly/experimental/symbolizer/Elf.cpp
-@@ -39,12 +39,10 @@
-
- #if defined(__ELF_NATIVE_CLASS)
- #define FOLLY_ELF_NATIVE_CLASS __ELF_NATIVE_CLASS
--#elif defined(__FreeBSD__)
--#if defined(__LP64__)
-+#elif defined(__LP64__)
- #define FOLLY_ELF_NATIVE_CLASS 64
- #else
- #define FOLLY_ELF_NATIVE_CLASS 32
--#endif
- #endif // __ELF_NATIVE_CLASS
-
- namespace folly {
---- a/folly/experimental/symbolizer/Elf.h
-+++ b/folly/experimental/symbolizer/Elf.h
-@@ -24,6 +24,7 @@
- #include <initializer_list>
- #include <stdexcept>
- #include <system_error>
-+#include <sys/types.h>
-
- #include <folly/Conv.h>
- #include <folly/Likely.h>
diff --git a/dev-cpp/folly/folly-2023.02.06.00.ebuild b/dev-cpp/folly/folly-2023.02.06.00.ebuild
deleted file mode 100644
index 0e5c76e971c1..000000000000
--- a/dev-cpp/folly/folly-2023.02.06.00.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# These must be bumped together:
-# dev-cpp/edencommon
-# dev-cpp/folly
-# dev-util/watchman
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- >=sys-libs/liburing-2.3:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs
- test? ( dev-cpp/gtest )"
-BDEPEND="test? ( sys-devel/clang )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2022.07.04.00-musl-fix.patch
-)
-
-pkg_setup() {
- [[ ${BUILD_TYPE} == binary ]] && return
-
- if use test && ! tc-is-clang ; then
- # Always build w/ Clang for now to avoid gcc ICE
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
- #if [[ $(gcc-major-version) -eq 12 ]] ; then
- # return
- #fi
-
- ## Only older GCC 11 is broken
- #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
- # return
- #fi
-
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # Fragile when changing compilers
- export CCACHE_DISABLE=1
-
- # TODO: liburing could in theory be optional but fails to link
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
-
- # https://github.com/gentoo/gentoo/pull/29393
- -DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- # - concurrent_hash_map_test.*
- # TODO: All SIGSEGV, report upstream!
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout|concurrent_hash_map_test.*)"
- )
-
- cmake_src_test
-}
diff --git a/dev-cpp/folly/folly-2023.05.22.00.ebuild b/dev-cpp/folly/folly-2023.05.22.00.ebuild
deleted file mode 100644
index 11d6692f182c..000000000000
--- a/dev-cpp/folly/folly-2023.05.22.00.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# These must be bumped together:
-# dev-cpp/edencommon
-# dev-cpp/folly
-# dev-util/watchman
-
-inherit cmake
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- >=sys-libs/liburing-2.3:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )
-"
-# libiberty is linked statically
-DEPEND="
- ${RDEPEND}
- sys-libs/binutils-libs
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2023.05.22.00-musl-fix.patch
-)
-
-src_unpack() {
- # Workaround for bug #889420
- mkdir -p "${S}" || die
- cd "${S}" || die
- default
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
-
- # https://github.com/gentoo/gentoo/pull/29393
- -DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- # - concurrent_hash_map_test.*
- # TODO: All SIGSEGV, report upstream!
- # - ssl_errors_test.SSLErrorsTest.TestMessage
- # Network...?
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout|concurrent_hash_map_test.*|ssl_errors_test.SSLErrorsTest.TestMessage)"
- )
-
- cmake_src_test
-}