summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-01-01 23:13:11 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-01-01 23:15:21 +0100
commit67c60aae7d5b24092f451eea77ca14ed7429daab (patch)
treef7877b7e19bec7b6202e6369fb61b1f89f8285ec /dev-ada
parentmedia-libs/libv4l: Patch to fix musl build for missing argp dependency (diff)
downloadgentoo-67c60aae7d5b24092f451eea77ca14ed7429daab.tar.gz
gentoo-67c60aae7d5b24092f451eea77ca14ed7429daab.tar.bz2
gentoo-67c60aae7d5b24092f451eea77ca14ed7429daab.zip
dev-ada/aunit: add 24.0.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/aunit/Manifest1
-rw-r--r--dev-ada/aunit/aunit-23.0.0-r1.ebuild3
-rw-r--r--dev-ada/aunit/aunit-24.0.0.ebuild38
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-ada/aunit/Manifest b/dev-ada/aunit/Manifest
index 0ab33f84dca9..e5f5c774ba3d 100644
--- a/dev-ada/aunit/Manifest
+++ b/dev-ada/aunit/Manifest
@@ -1 +1,2 @@
DIST aunit-23.0.0.tar.gz 131699 BLAKE2B 04ff77214ab6f4f5d59ea0609fffbc6fcfb4695d2fbbed45efa14e2b745c33868e1c134e5d00a7c3d8f11b1a8d15c6212110c78a53df4230b5862fb9b912a434 SHA512 450caa79e4808188107cd065665ca9cab599934e3934d18406b08d3ccebe26c1e95cd0c712ea3403d6082c7c5e8fd9ecf09ae3b63d231b80ad575048b3d61943
+DIST aunit-24.0.0.tar.gz 131699 BLAKE2B e43e7a94b278597475767d93f28a95a586abeaf45d141ea7035df9cb45d1be67c189a5be3d0364943b4649270f8f96d7cfd20fcba7a28917b14266c9e9424815 SHA512 25b973d1eb35e9e15ed24abe9c4ad7165d684c0e72abe619dcb9bec04cef8b28c78c1994e96e4bc29fd3b06567e15360f47ac87f49e1fa9888f55675defc226f
diff --git a/dev-ada/aunit/aunit-23.0.0-r1.ebuild b/dev-ada/aunit/aunit-23.0.0-r1.ebuild
index 50276ceec173..b40221d5658f 100644
--- a/dev-ada/aunit/aunit-23.0.0-r1.ebuild
+++ b/dev-ada/aunit/aunit-23.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,6 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
diff --git a/dev-ada/aunit/aunit-24.0.0.ebuild b/dev-ada/aunit/aunit-24.0.0.ebuild
new file mode 100644
index 000000000000..c31c1793e16c
--- /dev/null
+++ b/dev-ada/aunit/aunit-24.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
+inherit ada multiprocessing
+
+DESCRIPTION="Ada unit testing framework"
+HOMEPAGE="http://libre.adacore.com/tools/aunit/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+src_compile() {
+ emake GPROPTS_EXTRA="-j$(makeopts_jobs) -v -cargs ${ADAFLAGS}"
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ einstalldocs
+ mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
+ rmdir "${D}"/usr/share/examples || die
+ rm -r "${D}"/usr/share/gpr/manifests || die
+}
+
+src_test() {
+ emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
+}