summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-10-10 00:18:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-10-10 00:45:20 +0200
commit737554e80b3e535551cb55c90d894c1163eedc78 (patch)
treeefc2d58ae0c92939c8be7772b0c96da174d738de /app-vim
parentapp-text/languagetool: version bump. (diff)
downloadgentoo-737554e80b3e535551cb55c90d894c1163eedc78.tar.gz
gentoo-737554e80b3e535551cb55c90d894c1163eedc78.tar.bz2
gentoo-737554e80b3e535551cb55c90d894c1163eedc78.zip
app-vim/gnupg: version bump.
Closes: https://bugs.gentoo.org/709870 Closes: https://github.com/gentoo/gentoo/pull/22533 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gnupg/Manifest1
-rw-r--r--app-vim/gnupg/gnupg-2.7.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/gnupg/Manifest b/app-vim/gnupg/Manifest
index 1ad76e421bc9..2d883828ebcc 100644
--- a/app-vim/gnupg/Manifest
+++ b/app-vim/gnupg/Manifest
@@ -1 +1,2 @@
DIST gnupg-2.6.tar.bz2 12074 BLAKE2B d06e4637627187e1d276c3b485e22b35f0cba78a491d34f0884da7ad320f12a3443e40a7c0e7e3f27be03984380eb966d593a283d768bb834a1fefed05656dd3 SHA512 1b7307954aad751006286edebb80767951b9bd9a8eff4c4a57fa6030cb442ceca12730a82c76a2181e1da19cc4cc8be21ccd4f8a21817aedf42785d8ff4b61ac
+DIST gnupg-2.7.1.zip 16131 BLAKE2B 82e29fd95adc5d6690409ec136086be2f0f358143de0bd6ad53c095d4cdcebe47f463f30cc5f494c441222380b5fac3291a9a6f7937f487ad28702ed3e175873 SHA512 07599e981e55d7eac7b06169e9ce30d33374b01680ad0317d5e4b51addce22b195dbd7a22a2adc381dfb89bd66aad9c377b43f36e6a5b32b7c577462b149e0a2
diff --git a/app-vim/gnupg/gnupg-2.7.1.ebuild b/app-vim/gnupg/gnupg-2.7.1.ebuild
new file mode 100644
index 000000000000..af2368e71d4c
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3645"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=27359 -> ${P}.zip"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+S="${WORKDIR}/vim-${P}"
+
+RDEPEND="app-crypt/gnupg"
+
+BDEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt || die
+}