summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-10-13 13:16:06 -0700
committerZac Medico <zmedico@gentoo.org>2024-10-13 13:41:13 -0700
commit287212de4b3f86986906b0e93a5d96be46f9ad90 (patch)
tree8436dc4acdc4a58fc794dee60e8aea66e314263a /app-text
parentnet-misc/openssh: Stabilize 9.8_p1-r2 sparc, #940876 (diff)
downloadgentoo-287212de4b3f86986906b0e93a5d96be46f9ad90.tar.gz
gentoo-287212de4b3f86986906b0e93a5d96be46f9ad90.tar.bz2
gentoo-287212de4b3f86986906b0e93a5d96be46f9ad90.zip
app-text/editorconfig-core-c: add 0.12.9
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/editorconfig-core-c/Manifest1
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.9.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index 67f854da6f6e..c48b9ce60e8c 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1 +1,2 @@
DIST editorconfig-core-c-0.12.6.tar.gz 76525 BLAKE2B 2ffad6b22d72bd23eca9f0f1704d279323328e01b72a4a18a7181c998f088d7f8c0bb93549d8071e6723b8294b628fe6d1b503de7434be45770a2be9127c1cab SHA512 7cf69ed48c0d28694fc1f54cd8ae89202a3f0a13b5302fd316f50d0f99a606f54af9709874f0da75ad11ab6f4cc36edacb4cd8639717d44842a309140be3a968
+DIST editorconfig-core-c-0.12.9.tar.gz 77696 BLAKE2B 7edcf5f44fcf3acb7fc433a9ef1fc1343015f4e065b73f02937ce57677ca5caccb4aa9141c44e86c5dbeaad496e8387570b0cc92c733555d29e5001842f71018 SHA512 c5769871c8fc945f9fedf9d33803a4df03eadaee4b724243e6a653fb8418e35417c33c0f6ba8e1ea709d9841a21c7da36fd0fd696be5cc9ac36610812b9dd1f6
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.9.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.9.ebuild
new file mode 100644
index 000000000000..b6fb6eed3e84
--- /dev/null
+++ b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="EditorConfig core library written in C"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
+SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="cli doc"
+
+BDEPEND="doc? ( app-text/doxygen )"
+DEPEND="dev-libs/libpcre2:="
+RDEPEND="
+ ${DEPEND}
+ cli? ( !dev-python/editorconfig[cli] !<dev-python/editorconfig-editorconfig-0.12.4-r1 )
+"
+# Header-only
+DEPEND+=" dev-libs/uthash"
+
+src_prepare() {
+ # Don't install the static library.
+ sed -e '/install(TARGETS editorconfig_static/,+5d' -i src/lib/CMakeLists.txt || die
+
+ # Unbundle dev-libs/uthash
+ rm src/lib/utarray.h || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
+ -DBUILD_STATICALLY_LINKED_EXE=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+
+ if ! use cli; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}