summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-09 01:05:43 +0100
committerSam James <sam@gentoo.org>2023-10-09 01:22:33 +0100
commit1f891cc76e1580f4ce3fd09a3e2b121f278e1ff3 (patch)
treedee80395e5013a84b9f5a2f4f9f0e4aad129ba75 /app-text
parentdev-libs/libmaa: add github upstream metadata (diff)
downloadgentoo-1f891cc76e1580f4ce3fd09a3e2b121f278e1ff3.tar.gz
gentoo-1f891cc76e1580f4ce3fd09a3e2b121f278e1ff3.tar.bz2
gentoo-1f891cc76e1580f4ce3fd09a3e2b121f278e1ff3.zip
app-text/dictd: add 1.13.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dictd/Manifest1
-rw-r--r--app-text/dictd/dictd-1.13.1.ebuild130
-rw-r--r--app-text/dictd/files/dictd-1.13.1-version.patch65
3 files changed, 196 insertions, 0 deletions
diff --git a/app-text/dictd/Manifest b/app-text/dictd/Manifest
index 875e659dd7c0..5f213c8909a8 100644
--- a/app-text/dictd/Manifest
+++ b/app-text/dictd/Manifest
@@ -1 +1,2 @@
DIST dictd-1.13.0.tar.gz 395455 BLAKE2B 222ce7eee03083ee23066f43330cce0cda3041d2ee4a0d54b2e9f2ea18a77ec83f91fbb766bdad645bdcaeed0674361ba600a393e4cb6c42bab6be94098991f0 SHA512 86871aaf34a182d1d7aac1a1282d4a75f2d7c112c762e92f303924c324f665dae75c51e7ca91e3cc1dde2053ad8e2d1fd50a76934a5f84ff70975aa858e26439
+DIST dictd-1.13.1.tar.gz 395619 BLAKE2B 83caad8570e752575bf5fe39a41e4a7d564f3a255d4e4cb234661a56ed645dfb155bef8a89d4ecfebfefb2f03d4ab808c00f1c4eacaae883761e28817138526b SHA512 31a2e67feaa672e773b86d16ecb9f41fdcd2d5f907759cc110261af30147b3972a2c7d742b4d61b67eb3b8c84c08e179106b9a30e998a425c9b437ec933b03ea
diff --git a/app-text/dictd/dictd-1.13.1.ebuild b/app-text/dictd/dictd-1.13.1.ebuild
new file mode 100644
index 000000000000..80aabe281512
--- /dev/null
+++ b/app-text/dictd/dictd-1.13.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1 systemd
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/ https://sourceforge.net/projects/dict/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+LICENSE="GPL-1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="dbi judy minimal selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/dictd
+ acct-user/dictd
+ >=sys-apps/coreutils-6.10
+ dev-libs/libmaa
+ sys-libs/zlib
+ dbi? ( dev-db/libdbi )
+ judy? ( dev-libs/judy )
+"
+DEPEND="${RDEPEND}"
+# <gawk-3.1.6 makes tests fail.
+BDEPEND="
+ >=sys-apps/gawk-3.1.6
+ sys-devel/flex
+ app-alternatives/yacc
+"
+RDEPEND+=" selinux? ( sec-policy/selinux-dictd )"
+
+DOC_CONTENTS="
+ To start and use ${PN} you need to emerge at least one dictionary from
+ the app-dicts category with the package name starting with 'dictd-'.
+ To install all available dictionaries, emerge app-dicts/dictd-dicts.
+ ${PN} will NOT start without at least one dictionary.\n
+ \nIf you are running systemd, you will need to review the instructions
+ explained in /etc/dict/dictd.conf comments.
+"
+
+PATCHES=(
+ "${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
+ "${FILESDIR}"/dictd-1.12.0-build.patch
+ "${FILESDIR}"/dictd-1.13.0-lex.patch
+ "${FILESDIR}"/dictd-1.13.0-libtool.patch # bug #818535
+ "${FILESDIR}"/dictd-1.13.1-version.patch # bug #852884
+ "${FILESDIR}"/dictd-1.13.0-stack-smashing.patch # bug #908998
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:configure.in:configure.ac:' Makefile.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with dbi plugin-dbi) \
+ $(use_with judy plugin-judy) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/${PN} \
+ --sysconfdir="${EPREFIX}"/etc/dict
+}
+
+src_compile() {
+ # -j1 for bug #743292
+ if use minimal; then
+ emake -j1 dictfmt dictzip dictzip
+ else
+ emake -j1
+ fi
+}
+
+src_test() {
+ use minimal && return 0 # All tests are for dictd which we don't build...
+
+ if [[ ${EUID} -eq 0 ]]; then
+ # If dictd is run as root user (-userpriv) it drops its privileges to
+ # dictd user and group. Give dictd group write access to test directory.
+ chown :dictd "${WORKDIR}" "${S}/test" || die
+ chmod 770 "${WORKDIR}" "${S}/test" || die
+ fi
+
+ emake -j1 test
+}
+
+src_install() {
+ if use minimal; then
+ emake -j1 DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
+ else
+ default
+
+ # Don't install rfc2229.txt because it is non-free
+ dodoc doc/{dicf.ms,rfc.ms,rfc.sh}
+ dodoc doc/{security.doc,toc.ms}
+ dodoc -r examples
+
+ # conf files. For dict.conf see below.
+ insinto /etc/dict
+ for f in dictd.conf site.info colorit.conf; do
+ doins "${FILESDIR}/1.10.11/${f}"
+ done
+
+ # startups for dictd
+ newinitd "${FILESDIR}/1.10.11/dictd.initd" dictd
+ newconfd "${FILESDIR}/1.10.11/dictd.confd" dictd
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ fi
+
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+
+ insinto /etc/dict
+ doins "${FILESDIR}"/1.10.11/dict.conf
+
+ dodoc ANNOUNCE NEWS README TODO
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ if has_version sys-apps/systemd; then
+ ewarn "The default location for dicts has changed! If you've modified your"
+ ewarn "systemd units locally to point into /usr/lib/dict, please update it"
+ ewarn "to point at /usr/share/dict now."
+ fi
+}
diff --git a/app-text/dictd/files/dictd-1.13.1-version.patch b/app-text/dictd/files/dictd-1.13.1-version.patch
new file mode 100644
index 000000000000..c0ef4f1f594e
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.13.1-version.patch
@@ -0,0 +1,65 @@
+https://bugs.gentoo.org/852884
+
+From: orbea <orbea@riseup.net>
+Date: Sat, 18 Jun 2022 10:00:21 -0700
+Subject: [PATCH] configure: Set version directly in AC_INIT
+
+This avoids a command not found error in config.status.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -20,7 +20,7 @@
+
+ # Add a _letter_ if you change the version number and release your own version.
+ # Numbers are for the original author(s) only.
+-DICT_VERSION=@DICT_VERSION@
++DICT_VERSION=@PACKAGE_VERSION@
+
+ ifneq (,)
+ This makefile requires GNU Make.
+--- a/configure.in
++++ b/configure.in
+@@ -23,14 +23,10 @@ dnl CFLAGS and LDFLAGS should be settable on the make commandline
+ dnl for optimization and stripping.
+ dnl LIBOBJS is an automatically-generated list of extra objects we need
+
+-
+-define(VERSION, 1.13.1)
+-
+-
+ AC_PREREQ(2.53)
+ AC_REVISION($Revision: 1.144 $)
+
+-AC_INIT([dict],[VERSION],[dict-beta@dict.org])
++AC_INIT([dict],[1.13.1],[dict-beta@dict.org])
+
+ AC_CONFIG_SRCDIR([dictd.c])
+ AC_CONFIG_HEADER(config.h)
+@@ -40,8 +36,6 @@ LT_INIT
+ echo Configuring for dict
+ echo .
+
+-DICT_VERSION=VERSION
+-
+ AC_CANONICAL_HOST
+
+ AC_PROG_CC
+@@ -183,7 +177,6 @@ SBINDIR=`eval3 $sbindir`
+ LIBEXECDIR=`eval3 $libexecdir`
+ DATADIR=`eval3 $datadir`
+
+-AC_SUBST(DICT_VERSION)
+ AC_SUBST(USE_PLUGIN)
+ AC_SUBST(EXEEXT)
+ AC_SUBST(allsubdirs)
+--- a/dictdplugin-config.in
++++ b/dictdplugin-config.in
+@@ -24,7 +24,7 @@ while test $# -ne 0; do
+ usage
+ exit;;
+ --version)
+- echo @DICT_VERSION@
++ echo @PACKAGE_VERSION@
+ exit;;
+ --libs)
+ echo -L@libdir@