summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-03-16 12:46:34 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-16 12:47:16 +0100
commit430828e0ab67801e9ec8267a03503bc4137162cf (patch)
tree2d516f92c46f0642a85d92c567cc6eb0840924bb /app-text/xml2rfc
parentapp-crypt/sequoia-sq: add 0.28.0 (diff)
downloadgentoo-430828e0ab67801e9ec8267a03503bc4137162cf.tar.gz
gentoo-430828e0ab67801e9ec8267a03503bc4137162cf.tar.bz2
gentoo-430828e0ab67801e9ec8267a03503bc4137162cf.zip
app-text/xml2rfc: add 3.17.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/xml2rfc')
-rw-r--r--app-text/xml2rfc/Manifest1
-rw-r--r--app-text/xml2rfc/xml2rfc-3.17.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/xml2rfc/Manifest b/app-text/xml2rfc/Manifest
index dd022a7b8995..cacc6d3da544 100644
--- a/app-text/xml2rfc/Manifest
+++ b/app-text/xml2rfc/Manifest
@@ -1,2 +1,3 @@
DIST xml2rfc-3.15.3.gh.tar.gz 2857354 BLAKE2B 936c1f0c37d8de85b7a9966b6239da55dca090c3cb3e712a1198683244e436ccf6827fc6d00325e8c13a7be829af6954d311f690e4aa0367f2399c4d5cf9321f SHA512 3022bfc071e9bbef2e8e6b73c9c6539690e18f0935e3d22f99d1fc3faa642b75f998d6dfbd8d8c019f7fc789c38957994e06667870638dff8e907c928578c904
DIST xml2rfc-3.16.0.gh.tar.gz 2859379 BLAKE2B 537815a648b9f5ed59b37a82a29ee092b7e2ad3d10c191a08c752a43d3aed0b81270a855b3a3ee1df935a1d14192715e62f82fe15c2de98eddf329ac554a4ba5 SHA512 893a71bd33c6971103188e624b91d1370f8324bb2316a542fa9496c02368875582b57336e57abd8753e207d80a5aed508c15407ea734056f91002dde9aafdad2
+DIST xml2rfc-3.17.0.gh.tar.gz 2856289 BLAKE2B b48d83118c0bfc1044b703d22a5d1b132e3c9f07da91592ef416013fc3cd8a55ef9e9dc51c3e7725d560c0ccde76120e590fd19e1f36f5bbbe4c73f5d4683f4d SHA512 61dadf2d8308cfade6210af62a54b638a02f44ba586ecd73c8929813c7a7013da933d8ff72f4a1107665da9a952e7fa188cf5cc71c928207b056c4f36f46679d
diff --git a/app-text/xml2rfc/xml2rfc-3.17.0.ebuild b/app-text/xml2rfc/xml2rfc-3.17.0.ebuild
new file mode 100644
index 000000000000..ec6251e95adb
--- /dev/null
+++ b/app-text/xml2rfc/xml2rfc-3.17.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
+HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
+SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+RESTRICT="!test? ( test )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ dev-python/google-i18n-address[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+#src_test() {
+ # https://github.com/ietf-tools/xml2rfc/issues/561
+# emake tests-no-network
+#}