summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-31 19:18:52 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-10-31 19:39:10 +0100
commit3d84a921110e1e59c7b6fe34c55b225b212e4482 (patch)
treebc9c92a171e4b794dae1adf02b321d38fbf56045 /app-text/xml2rfc
parentapp-emulation/qtrvsim: drop 0.9.7 (diff)
downloadgentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.tar.gz
gentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.tar.bz2
gentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.zip
app-text/xml2rfc: add 3.24.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/xml2rfc')
-rw-r--r--app-text/xml2rfc/Manifest1
-rw-r--r--app-text/xml2rfc/xml2rfc-3.24.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/xml2rfc/Manifest b/app-text/xml2rfc/Manifest
index ee3a0790bec9..491c94d2ea1f 100644
--- a/app-text/xml2rfc/Manifest
+++ b/app-text/xml2rfc/Manifest
@@ -1,2 +1,3 @@
DIST xml2rfc-3.18.0.gh.tar.gz 2856552 BLAKE2B b2397d10c770694e8eb354220803f89525e64638fd1043c2672ce0849be72a397ab6f2bff03f689721f00e63ac034ec7b7aec20cf93b759f42a415ab66293908 SHA512 afd88bad84c6f5b734dd091e34ec41bff63fcf38f3bfab777818954dec31363300e13dd745b602e2c145fbe0df0be4e69918ddc71aac276bf0833ad4563c19f1
DIST xml2rfc-3.23.2.gh.tar.gz 2814581 BLAKE2B 25a27c90eff5260e41bf2503bc6959b1acfce494f4bd8f077b0664f776d524ca0572977443f1c839978062573356b6eae67d5efe4253c54168ade6fb34ce6c52 SHA512 443678d70d5d2f86e255f29aa6092d5db571be8f3a54a0b36f5d23e0b46fb426fb2a0b1cfecf2307b2cdbbba40113cd1944d1e70ef1e460a6c9596ba5e9a8bd4
+DIST xml2rfc-3.24.0.gh.tar.gz 2838316 BLAKE2B 3c6cfe36f041125b7ba2ef5f75f8fb8312f0d21d57e567905d47f9661cdc0bf2733e0f17441453fe85c2afa66bcf1fbb7a11a66b61201e717d5d3c5a5b73a449 SHA512 e89ed354f40304cc13f99e4e2b53abbf226b06b17bb47be677f7d1433de36ee957ea49a81dbe8b6c0d9310c602d71f9fb4650588cdd799076ade286463b6b3fb
diff --git a/app-text/xml2rfc/xml2rfc-3.24.0.ebuild b/app-text/xml2rfc/xml2rfc-3.24.0.ebuild
new file mode 100644
index 000000000000..63b878ca5350
--- /dev/null
+++ b/app-text/xml2rfc/xml2rfc-3.24.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
+HOMEPAGE="
+ https://ietf-tools.github.io/xml2rfc/
+ https://github.com/ietf-tools/xml2rfc/
+ https://pypi.org/project/xml2rfc/
+"
+SRC_URI="
+ https://github.com/ietf-tools/xml2rfc/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/platformdirs-3.6.0[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ >=dev-python/google-i18n-address-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # Disable broken PdfWriterTests.
+ sed -i 's/ PdfWriterTests(unittest.TestCase):/ PdfWriterTests:/' test.py || die
+}