summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/teckit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/teckit')
-rw-r--r--app-text/teckit/Manifest2
-rw-r--r--app-text/teckit/files/teckit-2.5.1-gcc43.patch12
-rw-r--r--app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch16
-rw-r--r--app-text/teckit/files/teckit-2.5.1-rc.patch15
-rw-r--r--app-text/teckit/metadata.xml5
-rw-r--r--app-text/teckit/teckit-2.5.1.ebuild43
-rw-r--r--app-text/teckit/teckit-2.5.3.ebuild44
7 files changed, 137 insertions, 0 deletions
diff --git a/app-text/teckit/Manifest b/app-text/teckit/Manifest
new file mode 100644
index 000000000000..ac2e338ed710
--- /dev/null
+++ b/app-text/teckit/Manifest
@@ -0,0 +1,2 @@
+DIST TECkit_2.5.3.tar.gz 2417611 SHA256 c048f1bdcfe3d361574818ca693e15295ece124f66db651f96c50379ae353e0c SHA512 7d2d315a38fa8df82a6180bfcd4737f5b9c664ff27d723c9dfd51902e0aa195d1eba4b49665cd22a2bbf28a9626b3569cb8aceb74b6f390c12c108a748a2e49e WHIRLPOOL 72046c709c1a2a12c52511669c4d0a3bca3800086041fa3cc15fb9d35274ea670bc4f1de19c574982fcea4aeff1824863dd57d96de010b36ca4d80fed8a599cc
+DIST TECkit_2_5_1.tar.gz 2630207 SHA256 59a01952684c4599a7f30b4f0deedcb6276f04fce73ac6fcbcbd55c4e2e6513a SHA512 db38ead681a5f3005769bf86bd39e3e769836885f672aea593284f0ad90932827697c30244944097ac4173633e6d0daa86e993136f179c4634440384811b418c WHIRLPOOL 2967688f1d78b3c1f2c42a72c12bf7c8c612d182a232432d2083e4e1b05d2bd92115fe28e8bc29596414c7e81da7fc48277666141e39f217d7cb9ea09a46c5c2
diff --git a/app-text/teckit/files/teckit-2.5.1-gcc43.patch b/app-text/teckit/files/teckit-2.5.1-gcc43.patch
new file mode 100644
index 000000000000..f5a6bfddcfa2
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-gcc43.patch
@@ -0,0 +1,12 @@
+Index: TECkit_2_5_1/source/Compiler.cpp
+===================================================================
+--- TECkit_2_5_1.orig/source/Compiler.cpp
++++ TECkit_2_5_1/source/Compiler.cpp
+@@ -29,6 +29,7 @@ Description:
+
+ #include "Compiler.h"
+
++#include <cstdio>
+ #include <iostream>
+ #include <iomanip>
+ #include <algorithm>
diff --git a/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
new file mode 100644
index 000000000000..5a290f45133b
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
@@ -0,0 +1,16 @@
+No need to pass CFLAGS twice, esp. if they are used to feed g++
+Bug #338110
+
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -76,7 +76,7 @@ noexpat_CFLAGS="$CFLAGS"
+ noexpat_LIBS="$LIBS"
+ AC_CHECK_LIB(expat, XML_ExpatVersion)
+ AM_CONDITIONAL(SYSTEM_EXPAT, test x$ac_cv_lib_expat_XML_ExpatVersion = xyes)
+-expat_CFLAGS="$CFLAGS"
++expat_CFLAGS=""
+ expat_LIBS="$LIBS"
+ CFLAGS="$noexpat_CFLAGS"
+ LIBS="$noexpat_LIBS"
diff --git a/app-text/teckit/files/teckit-2.5.1-rc.patch b/app-text/teckit/files/teckit-2.5.1-rc.patch
new file mode 100644
index 000000000000..a4f1a3fae5d6
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-rc.patch
@@ -0,0 +1,15 @@
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -15,10 +15,6 @@ AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+
+-if test "${target_os}" = "mingw32"; then
+-AC_PROG_RC
+-fi
+-
+ AC_ARG_WITH(old-lib-names,
+ [ --with-old-lib-names Use old library names (for Windows only)],
+ [case "${withval}" in
diff --git a/app-text/teckit/metadata.xml b/app-text/teckit/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/teckit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/app-text/teckit/teckit-2.5.1.ebuild b/app-text/teckit/teckit-2.5.1.ebuild
new file mode 100644
index 000000000000..8abefdeb1e40
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+MY_P=TECkit_${PV//./_}
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="http://scripts.sil.org/svn-view/teckit/TAGS/${MY_P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-rc.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}
diff --git a/app-text/teckit/teckit-2.5.3.ebuild b/app-text/teckit/teckit-2.5.3.ebuild
new file mode 100644
index 000000000000..300bda9b0712
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P=TECkit_${PV}
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+# Upstream regenerates tarballs at each fetch, breaking checksums:
+# SRC_URI="http://scripts.sil.org/svn-view/teckit/TAGS/${MY_P}.tar.gz"
+# https://bugs.gentoo.org/show_bug.cgi?id=554972
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}