summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/rman/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/rman/files')
-rw-r--r--app-text/rman/files/rman-3.2-format-security.patch16
-rw-r--r--app-text/rman/files/rman-3.2-gentoo.diff19
-rw-r--r--app-text/rman/files/rman-3.2-ldflags.patch13
3 files changed, 48 insertions, 0 deletions
diff --git a/app-text/rman/files/rman-3.2-format-security.patch b/app-text/rman/files/rman-3.2-format-security.patch
new file mode 100644
index 000000000000..77070026bdb9
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-format-security.patch
@@ -0,0 +1,16 @@
+ rman.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rman.c b/rman.c
+index d09e547..e5fc88d 100644
+--- a/rman.c
++++ b/rman.c
+@@ -1372,7 +1372,7 @@ HTML(enum command cmd) {
+ break;
+ case BEGINSECTION: break;
+ case ENDSECTION:
+- if (sectheadid==NAME && message!=NULL) printf(message);
++ if (sectheadid==NAME && message!=NULL) printf("%s", message);
+ break;
+ case BEGINSUBSECTION: break;
+ case ENDSUBSECTION: break;
diff --git a/app-text/rman/files/rman-3.2-gentoo.diff b/app-text/rman/files/rman-3.2-gentoo.diff
new file mode 100644
index 000000000000..ece1e3807e66
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-gentoo.diff
@@ -0,0 +1,19 @@
+diff -urN rman-3.2.orig/Makefile rman-3.2/Makefile
+--- rman-3.2.orig/Makefile 2003-07-26 12:15:00.000000000 -0700
++++ rman-3.2/Makefile 2005-07-12 01:01:37.000000000 -0700
+@@ -15,13 +15,8 @@
+ # this must be a directory that's in your bin PATH.
+ # MANDIR holds the man page.
+
+-BINDIR = /opt/local/bin
+-#BINDIR = /usr/local/bin
+-#BINDIR = //C/bin
+-MANDIR = /usr/local/man/man1
+-# popular alternative
+-#BINDIR = /opt/local/bin
+-#MANDIR = /opt/local/man/man1
++BINDIR = /usr/bin
++MANDIR = /usr/share/man/man1
+
+
+ ### if you have GNU gcc, use these definitions
diff --git a/app-text/rman/files/rman-3.2-ldflags.patch b/app-text/rman/files/rman-3.2-ldflags.patch
new file mode 100644
index 000000000000..4a6f5f5d9eab
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-ldflags.patch
@@ -0,0 +1,13 @@
+Index: rman-3.2/Makefile
+===================================================================
+--- rman-3.2.orig/Makefile
++++ rman-3.2/Makefile
+@@ -102,7 +102,7 @@ all: rman
+
+ # everyone but me zaps assertions with the -DNDEBUG flag
+ rman: rman.c Makefile
+- $(CC) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
++ $(CC) $(LDFLAGS) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
+
+
+ debug: