summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-02 13:51:21 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-02 13:53:34 +0100
commit4e052834b275d58a120045487692c74e3d094385 (patch)
treeff8062c609b6117dc5662443dbf543dffe996388 /app-text/nuspell/nuspell-4.0.1.ebuild
parentdev-python/bluelet: Stabilize 0.2.0 amd64, #749912 (diff)
downloadgentoo-4e052834b275d58a120045487692c74e3d094385.tar.gz
gentoo-4e052834b275d58a120045487692c74e3d094385.tar.bz2
gentoo-4e052834b275d58a120045487692c74e3d094385.zip
app-text/nuspell: 4.0.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'app-text/nuspell/nuspell-4.0.1.ebuild')
-rw-r--r--app-text/nuspell/nuspell-4.0.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/nuspell/nuspell-4.0.1.ebuild b/app-text/nuspell/nuspell-4.0.1.ebuild
new file mode 100644
index 000000000000..eae5d180a1bc
--- /dev/null
+++ b/app-text/nuspell/nuspell-4.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/4" # due to libnuspell.so.4
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}