summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-09-29 15:05:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-09-29 15:05:19 +0200
commitfef29dc3806e6e1950a7884f82794451f1182e95 (patch)
tree35812252529b0ac36d7c914eb016de6868713965 /app-text/mandoc
parentgames-puzzle/five-or-more: add missing librsvg[vala] bdep (diff)
downloadgentoo-fef29dc3806e6e1950a7884f82794451f1182e95.tar.gz
gentoo-fef29dc3806e6e1950a7884f82794451f1182e95.tar.bz2
gentoo-fef29dc3806e6e1950a7884f82794451f1182e95.zip
app-text/mandoc: Bump to version 1.14.6
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/mandoc')
-rw-r--r--app-text/mandoc/Manifest1
-rw-r--r--app-text/mandoc/mandoc-1.14.6.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/app-text/mandoc/Manifest b/app-text/mandoc/Manifest
index f44b4b353ca7..a8738ed240ba 100644
--- a/app-text/mandoc/Manifest
+++ b/app-text/mandoc/Manifest
@@ -1 +1,2 @@
DIST mandoc-1.14.5.tar.gz 651846 BLAKE2B 27aaf97e7226e989b33861d2a255304bb64a7cd43ca026568f4b044035241c3315a0d73673b023d9ca5b80575b8c584889832bbd86b80aaa49bb785b37559367 SHA512 848f290847f3095757f25647e6d73eb7044018b145bf6f9dc8b5db164b1421911efdc5b3b9022ec3a2c5af9687a84d5acedee810f2bd2f7caaa9242dadb2cc52
+DIST mandoc-1.14.6.tar.gz 697150 BLAKE2B e9f6087e9df977901815b1231f68e381502c7392b0ac65a060ce0ef270da3b76540a17931a076b700865a02f9ca1a8ca044a54dbf6318756931c29e6b1deb228 SHA512 54286070812a47b629f68757046d3c9a1bdd2b5d1c3b84a5c8e4cb92f1331afa745443f7238175835d8cfbe5b8dd442e00c75c3a5b5b8f8efd8d2ec8f636dad4
diff --git a/app-text/mandoc/mandoc-1.14.6.ebuild b/app-text/mandoc/mandoc-1.14.6.ebuild
new file mode 100644
index 000000000000..c533b6e8298f
--- /dev/null
+++ b/app-text/mandoc/mandoc-1.14.6.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of tools compiling mdoc and man"
+HOMEPAGE="https://mdocml.bsd.lv/"
+SRC_URI="https://mdocml.bsd.lv/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="cgi system-man"
+
+RDEPEND="sys-libs/zlib
+ system-man? ( !sys-apps/man-db )
+"
+DEPEND="${RDEPEND}
+ cgi? ( sys-libs/zlib[static-libs] )
+"
+BDEPEND="
+ cgi? ( app-text/highlight )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.5-r1-www-install.patch
+)
+
+pkg_pretend() {
+ if use system-man ; then
+ # only support uncompressed and gzip
+ [[ -n ${PORTAGE_COMPRESS+unset} ]] && \
+ [[ "${PORTAGE_COMPRESS}" == "gzip" || "${PORTAGE_COMPRESS}" == "" ]] || \
+ ewarn "only PORTAGE_COMPRESS=gzip or '' is supported, man pages will not be indexed"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # The db-install change is to support parallel installs.
+ sed -i \
+ -e '/ar rs/s:ar:$(AR):' \
+ -e '/^db-install:/s:$: base-install:' \
+ Makefile || die
+
+ # make-4.3 doesn't like the CC line (bug #706024)
+ # and "echo -n" is not portable
+ sed \
+ -e "s@^\(CC=\).*\$@\1\"$(tc-getCC)\"@" \
+ -e 's@echo -n@printf@g' \
+ -i configure || die
+
+ cat <<-EOF > "configure.local"
+ PREFIX="${EPREFIX}/usr"
+ BINDIR="${EPREFIX}/usr/bin"
+ SBINDIR="${EPREFIX}/usr/sbin"
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ MANDIR="${EPREFIX}/usr/share/man"
+ INCLUDEDIR="${EPREFIX}/usr/include/mandoc"
+ EXAMPLEDIR="${EPREFIX}/usr/share/examples/mandoc"
+ MANPATH_DEFAULT="${EPREFIX}/usr/man:${EPREFIX}/usr/share/man:${EPREFIX}/usr/local/man:${EPREFIX}/usr/local/share/man"
+
+ CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ # The STATIC variable is only used by man.cgi.
+ STATIC=
+
+ # conflicts with sys-apps/groff
+ BINM_SOELIM=msoelim
+ MANM_ROFF=mandoc_roff
+ # conflicts with sys-apps/man-pages
+ MANM_MAN=mandoc_man
+
+ # fix utf-8 locale on musl
+ $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+ EOF
+ use system-man || cat <<-EOF >> "configure.local"
+ BINM_MAN=mman
+ BINM_APROPOS=mapropos
+ BINM_WHATIS=mwhatis
+ BINM_MAKEWHATIS=mmakewhatis
+ MANM_MDOC=mandoc_mdoc
+ MANM_EQN=mandoc_eqn
+ MANM_TBL=mandoc_tbl
+ MANM_MANCONF=mman.conf
+ EOF
+ if use cgi; then
+ cp cgi.h{.example,} || die
+ fi
+ if [[ -n "${MANDOC_CGI_H}" ]]; then
+ cp "${MANDOC_CGI_H}" cgi.h || die
+ fi
+
+ # ./configure does not propagate all configure.local
+ # settings to Makefile.local settings.
+ tc-export AR
+}
+
+src_compile() {
+ default
+ use cgi && emake man.cgi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use cgi && emake DESTDIR="${D}" cgi-install www-install
+
+ if use system-man ; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/mandoc.cron-r0 mandoc
+ fi
+}
+
+pkg_postinst() {
+ if use system-man ; then
+ elog "Generating mandoc database"
+ makewhatis || die
+ fi
+}