summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-16 19:11:18 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-16 19:11:18 +0100
commit1530d1a646ed99a3491594a315d6fdd2a2ef2c54 (patch)
treeffd5ee63741451ca33e37ba1ccaad31f303fe6a8 /app-text/libwps/libwps-0.4.6.ebuild
parentdev-db/mariadb: ppc64 stable (bug 611316). (diff)
downloadgentoo-1530d1a646ed99a3491594a315d6fdd2a2ef2c54.tar.gz
gentoo-1530d1a646ed99a3491594a315d6fdd2a2ef2c54.tar.bz2
gentoo-1530d1a646ed99a3491594a315d6fdd2a2ef2c54.zip
app-text/libwps: Version bump 0.4.6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'app-text/libwps/libwps-0.4.6.ebuild')
-rw-r--r--app-text/libwps/libwps-0.4.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/libwps/libwps-0.4.6.ebuild b/app-text/libwps/libwps-0.4.6.ebuild
new file mode 100644
index 000000000000..93c2ec4fbaa7
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+IUSE="doc debug static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --with-sharedptr=c++11 \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}