summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 00:34:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 00:34:35 +0200
commitf39664e2abc1387141a5172304b9301a9130bf8c (patch)
tree77ba25146145802f0b0233d91d092f8751dbc5c3 /app-text/libepubgen/libepubgen-0.1.1.ebuild
parentmedia-libs/vigra: Remove old (diff)
downloadgentoo-f39664e2abc1387141a5172304b9301a9130bf8c.tar.gz
gentoo-f39664e2abc1387141a5172304b9301a9130bf8c.tar.bz2
gentoo-f39664e2abc1387141a5172304b9301a9130bf8c.zip
app-text/libepubgen: 0.1.1 version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/libepubgen/libepubgen-0.1.1.ebuild')
-rw-r--r--app-text/libepubgen/libepubgen-0.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/libepubgen/libepubgen-0.1.1.ebuild b/app-text/libepubgen/libepubgen-0.1.1.ebuild
new file mode 100644
index 000000000000..2fe034fa1608
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-util/cppunit
+ dev-libs/libxml2:2
+ )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}