summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-10-30 14:59:14 -0700
committerRafael Martins <rafaelmartins@gentoo.org>2016-10-30 14:59:31 -0700
commitd4a30cb71f6ecb47daa626914c3111d0fa5a78cf (patch)
tree4e70f399fba7854bb2e0aa6898c8abf8c6556be4 /app-text/blogc/blogc-0.12.0.ebuild
parentdev-python/pydns: bump. (diff)
downloadgentoo-d4a30cb71f6ecb47daa626914c3111d0fa5a78cf.tar.gz
gentoo-d4a30cb71f6ecb47daa626914c3111d0fa5a78cf.tar.bz2
gentoo-d4a30cb71f6ecb47daa626914c3111d0fa5a78cf.zip
app-text/blogc: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text/blogc/blogc-0.12.0.ebuild')
-rw-r--r--app-text/blogc/blogc-0.12.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/blogc/blogc-0.12.0.ebuild b/app-text/blogc/blogc-0.12.0.ebuild
new file mode 100644
index 000000000000..39b3f47aeeb6
--- /dev/null
+++ b/app-text/blogc/blogc-0.12.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="
+ git://github.com/blogc/blogc.git
+ https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable httpd runserver) \
+ --disable-valgrind \
+ ${myconf}
+}