summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2021-12-22 09:32:41 +0500
committerFabian Groffen <grobian@gentoo.org>2021-12-22 14:20:33 +0100
commit5f9ccfdbe32fb1b0acc380c5098cb723182250f7 (patch)
treea3c04df57b5e8a844979179c3db4801f8b4c0377 /app-text/antiword
parentnet-fs/autofs: fix nfsv4 mount issue (diff)
downloadgentoo-5f9ccfdbe32fb1b0acc380c5098cb723182250f7.tar.gz
gentoo-5f9ccfdbe32fb1b0acc380c5098cb723182250f7.tar.bz2
gentoo-5f9ccfdbe32fb1b0acc380c5098cb723182250f7.zip
app-text/antiword: revbump (EAPI 5 -> 8)
Closes: https://bugs.gentoo.org/829790 Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/antiword-0.37-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/antiword/antiword-0.37-r2.ebuild b/app-text/antiword/antiword-0.37-r2.ebuild
new file mode 100644
index 000000000000..1b0fc3a45055
--- /dev/null
+++ b/app-text/antiword/antiword-0.37-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+PATCHVER="r2"
+DESCRIPTION="free MS Word reader"
+HOMEPAGE="http://www.winfield.demon.nl"
+SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/${PN}-gentoo-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-gentoo-patches-${PATCHVER}
+ "${FILESDIR}"/${P}-CVE-2014-8123.patch
+)
+
+DOCS=( Docs/{ChangeLog,Exmh,Emacs,FAQ,History,Netscape,QandA,ReadMe,Mozilla,Mutt} )
+
+src_prepare() {
+ # Makefile is a symlink to Makefile.Linux, avoid that we patch it by
+ # accident using patch <2.7, see bug #435492
+ rm Makefile || die
+
+ default
+
+ # Re-add convenience symlink, see above
+ ln -s Makefile.Linux Makefile
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}" OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install
+
+ einstalldocs
+
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc Docs/testdoc.doc Docs/antiword.php
+
+ doman Docs/antiword.1
+}