summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-05 17:26:10 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-05 17:28:57 +0100
commit0c1941d435f9c8c189f881fcccd1fc14cb8cfac8 (patch)
treee577061b98755013f8e3903a9d377ea77299038b /app-text/an
parentapp-text/wscr: EAPI=7 (diff)
downloadgentoo-0c1941d435f9c8c189f881fcccd1fc14cb8cfac8.tar.gz
gentoo-0c1941d435f9c8c189f881fcccd1fc14cb8cfac8.tar.bz2
gentoo-0c1941d435f9c8c189f881fcccd1fc14cb8cfac8.zip
app-text/an: Version 1.2_p6
- Apply Debian patch (set) - DEPEND on virtual/pkgconfig (see Debian patch) - EAPI=7 - Remove redundant sed scripts Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/an')
-rw-r--r--app-text/an/Manifest1
-rw-r--r--app-text/an/an-1.2_p6.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/an/Manifest b/app-text/an/Manifest
index 33eb47696d08..5f54ec324855 100644
--- a/app-text/an/Manifest
+++ b/app-text/an/Manifest
@@ -1 +1,2 @@
+DIST an_1.2-6.debian.tar.xz 4432 BLAKE2B efec93daf46b30369aa5d6a6bc57b9e79db7aabea5d8cb7ec9305775bf05c693c3b2ea428c09b99b2350f8a168e2b7e810538d78c321b11a64e6ca804f56feb8 SHA512 33cd93ddf1dea5f1a8d94695dbf6fcfbdf58830c11be1d6c83e516f6dc6d11adbe0cb196c98ec094887021575adc68aaa667222d3b10ed40e87e55a5422deaf2
DIST an_1.2.orig.tar.xz 13196 BLAKE2B bbb19eb16e558f8fc3d331e5ad308611b13a7a88a65fb310b678bd21d46c39761747fb6f60a7eba99a1c2e756a8c9467543d26e97bbf7f9c93d17f66a4d7698c SHA512 919c525aa1215e3c1b2200c6820a357c6406c19b7447147cc4243d339c554b9892bea11797769df0bf96dd72c89f61bf3d977769faf9bc7f9edf609a7daeac3d
diff --git a/app-text/an/an-1.2_p6.ebuild b/app-text/an/an-1.2_p6.ebuild
new file mode 100644
index 000000000000..fd837055287f
--- /dev/null
+++ b/app-text/an/an-1.2_p6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="https://packages.debian.org/unstable/games/an"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.xz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-libs/icu:=
+ sys-apps/miscfiles[-minimal]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ default
+
+ eapply $(
+ for patch in $(cat "${WORKDIR}"/debian/patches/series)
+ do
+ echo "${WORKDIR}"/debian/patches/$patch
+ done
+ )
+
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}