summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard-Rogalski <rrogalski@tutanota.com>2022-02-26 16:16:06 -0600
committerSam James <sam@gentoo.org>2022-02-27 00:55:45 +0000
commita9ae0068e8500b97d36b85efde823cdaed35be61 (patch)
tree0e1a597d3444424e21db9e9a4e91dcb41f95b3e1 /app-shells
parentsci-libs/cantera: drop desktop.eclass in -r3 (diff)
downloadgentoo-a9ae0068e8500b97d36b85efde823cdaed35be61.tar.gz
gentoo-a9ae0068e8500b97d36b85efde823cdaed35be61.tar.bz2
gentoo-a9ae0068e8500b97d36b85efde823cdaed35be61.zip
app-shells/rc: fix bug preventing rc becoming login shell
Previously the path /bin/rcsh was appended to /etc/shells despite the ebuild installing to /usr/bin/rcsh. This new revision appends the proper path in /etc/shells Closes: https://bugs.gentoo.org/830633 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Richard Rogalski <rrogalski@tutanota.com> Closes: https://github.com/gentoo/gentoo/pull/24366 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rc/rc-1.7.4-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/rc/rc-1.7.4-r2.ebuild b/app-shells/rc/rc-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..1f68bd85ca1b
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline:0 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=edit"
+
+ econf "${myconf}"
+}
+
+src_install() {
+ into /usr
+ newbin "${PN}" "${PN}sh"
+ newman "${PN}.1" "${PN}sh.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! grep -q '^/usr/bin/rcsh$' "${EROOT}"/etc/shells ; then
+ ebegin "Updating /etc/shells"
+ echo "/usr/bin/rcsh" >> "${EROOT}"/etc/shells
+ eend $?
+ fi
+}