summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-30 18:52:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-30 18:58:46 +0300
commit7856f0680bca521f327c61fb770b1a4f683c7c0d (patch)
treeee12a419fe3a5078cbd025fc7d0698bbcda34714 /app-shells/mksh
parentmedia-libs/harfbuzz: drop 8.4.0 (diff)
downloadgentoo-7856f0680bca521f327c61fb770b1a4f683c7c0d.tar.gz
gentoo-7856f0680bca521f327c61fb770b1a4f683c7c0d.tar.bz2
gentoo-7856f0680bca521f327c61fb770b1a4f683c7c0d.zip
app-shells/mksh: drop 9999
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells/mksh')
-rw-r--r--app-shells/mksh/mksh-9999.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/app-shells/mksh/mksh-9999.ebuild b/app-shells/mksh/mksh-9999.ebuild
deleted file mode 100644
index 9154bea1a42e..000000000000
--- a/app-shells/mksh/mksh-9999.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]] ; then
- ECVS_SERVER="anoncvs.mirbsd.org:/cvs"
- ECVS_MODULE="mksh"
- ECVS_USER="_anoncvs"
- ECVS_AUTH="ext"
- inherit cvs
-else
- SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MirBSD Korn Shell"
-# Host is TLSv1.0-only, keep to http for compatibility with modern browsers
-HOMEPAGE="http://mirbsd.de/mksh"
-
-# See http://www.mirbsd.org/TaC-mksh.txt or ${S}/www/files/TaC-mksh.txt
-# MirOS for most of it
-# BSD for when strlcpy(3) is absent, such as with glibc
-# unicode for some included Unicode data
-# ISC if the printf builtin is used, not currently the case
-LICENSE="MirOS BSD unicode"
-SLOT="0"
-IUSE="lksh static test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-lang/perl
- sys-apps/ed
- )
-"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- default
- if use lksh; then
- cp -pr "${S}" "${S}"_lksh || die
- fi
-}
-
-src_compile() {
- tc-export CC
- use static && export LDSTATIC="-static"
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
-
- if use lksh; then
- pushd "${S}"_lksh >/dev/null || die
- CPPFLAGS="${CPPFLAGS} -DMKSH_BINSHPOSIX -DMKSH_BINSHREDUCED" \
- sh Build.sh -r -L || die
- popd >/dev/null || die
- fi
-
- sh Build.sh -r || die
- sh FAQ2HTML.sh || die
-}
-
-src_test() {
- einfo "Testing regular mksh."
- ./mksh test.sh -v || die
-
- if use lksh; then
- einfo "Testing lksh, POSIX long-bit mksh."
- pushd "${S}"_lksh >/dev/null || die
- ./lksh test.sh -v || die
- popd >/dev/null || die
- fi
-}
-
-src_install() {
- into /
- dobin mksh
- dosym mksh /bin/rmksh
- doman mksh.1
- dodoc dot.mkshrc
- dodoc FAQ.htm
-
- if use lksh; then
- dobin "${S}"_lksh/lksh
- dosym lksh /bin/rlksh
- doman "${S}"_lksh/lksh.1
- fi
-}