summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 14:25:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 14:32:34 +0200
commitd57afa9cd93c0705642436f82cf5afb184b86e59 (patch)
tree7767eac09f26ae7309adddd057679a5f33417cff /app-portage
parentdev-python/ftfy: Enable py3.13 (diff)
downloadgentoo-d57afa9cd93c0705642436f82cf5afb184b86e59.tar.gz
gentoo-d57afa9cd93c0705642436f82cf5afb184b86e59.tar.bz2
gentoo-d57afa9cd93c0705642436f82cf5afb184b86e59.zip
app-portage/gemato: Bump to 20.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-20.6.ebuild49
-rw-r--r--app-portage/gemato/gemato-9999.ebuild2
3 files changed, 51 insertions, 1 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index fc6ef1cb2a13..980d0f8d41ce 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-20.5.tar.gz 88598 BLAKE2B dadbdd0275b6a79bb1c288d85ccb41600715c5e582b0d427a7fca5f08a8390200929b3de921bb7bd56f4a155fd9d979baaccb29a75c119c418c3ab62202f2856 SHA512 427e198b0630a18f219739dc093ddd0752a9b9871cd4ebf78b035c315bb49e4a5a639811d5fc26a17446c29eeea133e5cb97bb38fe89e2f74a6a320fd9bf5f0a
+DIST gemato-20.6.tar.gz 87376 BLAKE2B ba7dad60ee44059e742ccd20b99eb6710c28250ecb0b11dc169c9a3e02ca0499e8d11587fe2ab878a86335e7a297fa70af2d87c9bd096ecaf8a20969a02a2cf7 SHA512 84d7eb5046ecc8465ccfeb3a97c8cd2b1512a5d3128458b053244dcfa40b69d2c3faf8bd6791fffdd7ea271e6d7a28d74096398a9208526a9eda542c2708b899
diff --git a/app-portage/gemato/gemato-20.6.ebuild b/app-portage/gemato/gemato-20.6.ebuild
new file mode 100644
index 000000000000..d38dc7551ba5
--- /dev/null
+++ b/app-portage/gemato/gemato-20.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index 9f78bf067f39..0a4f52cf18cb 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
"
EGIT_REPO_URI="https://github.com/projg2/gemato.git"
-LICENSE="BSD-2"
+LICENSE="GPL-2+"
SLOT="0"
IUSE="+gpg pretty-log tools"