summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 11:30:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:09 +0100
commit5fb842f501bde33121424b434a4eb178b78bd4ca (patch)
tree5385ea16b54067a327113130932aa97e9ca5c900 /app-portage
parentapp-portage/smart-live-rebuild: Update the live ebuild (diff)
downloadgentoo-5fb842f501bde33121424b434a4eb178b78bd4ca.tar.gz
gentoo-5fb842f501bde33121424b434a4eb178b78bd4ca.tar.bz2
gentoo-5fb842f501bde33121424b434a4eb178b78bd4ca.zip
app-portage/smart-live-rebuild: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/Manifest1
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index 95ffd8481afc..87ee04b91fd3 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1 +1,2 @@
DIST smart-live-rebuild-1.3.7.tar.gz 17283 BLAKE2B 9de30e07b7c950c7e0e3d7f20a364ef65028fe425a017cf46de73a4aaa2c82f13359bc8e2d3269ed50b201b95c41af16c6f233576c1176f8c9b6394227bc8e14 SHA512 47111fa0e4ef9630a60b262566166822ac3245338c9cabc9e5959922e6f60cac70087025321fc9946ef7527b02ce7eb25d74e22d045f9e875c82d6f7877feb4b
+DIST smart-live-rebuild-1.4.0.tar.gz 17630 BLAKE2B 84faabbe702dc05dbd895961dba83b8b8968bafcc5e35bd1b7dc8644f98a904651168aaee081ecb0c101761def2f5d49046116179156e75f6b335a79595d82e6 SHA512 add82ac413c698a430afbb48a7d4c7d0dae26b9d37f01dcbe7f71ee2e2fbc1686ff63c6ea9ae1c24dbc3662d27247bec2ccc002841bd42c4c11729873a49617f
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
new file mode 100644
index 000000000000..70bc47266ae7
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}