summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:29 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:52 +0100
commit5f5263a3516f1623c6b16af0d552eb53eb7a0c07 (patch)
treebaf199766054b84edd54abd8b985e5e18ec7a3d3 /app-portage
parentdev-haskell/parser-combinators: new package, add 1.3.0 (diff)
downloadgentoo-5f5263a3516f1623c6b16af0d552eb53eb7a0c07.tar.gz
gentoo-5f5263a3516f1623c6b16af0d552eb53eb7a0c07.tar.bz2
gentoo-5f5263a3516f1623c6b16af0d552eb53eb7a0c07.zip
app-portage/hackport: add 0.8.4.0, update 9999
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/hackport/Manifest1
-rw-r--r--app-portage/hackport/files/hackport.bash.completion14
-rw-r--r--app-portage/hackport/hackport-0.8.4.0.ebuild87
-rw-r--r--app-portage/hackport/hackport-9999.ebuild101
-rw-r--r--app-portage/hackport/metadata.xml8
5 files changed, 169 insertions, 42 deletions
diff --git a/app-portage/hackport/Manifest b/app-portage/hackport/Manifest
index 58280c789e04..64c31175a24d 100644
--- a/app-portage/hackport/Manifest
+++ b/app-portage/hackport/Manifest
@@ -1 +1,2 @@
DIST hackport-0.7.2.2.tar.gz 2083323 BLAKE2B e14fbd5c5fa88260518869ad72dd59d08e7cb4351cecc35952ebfdd71e34ea335e6c4b56de7577033335e3efdbff8796fd05f1ad3df20ae84ed1bc8ef7b2153f SHA512 ce880ae8a5a4dc1d446654b8bf4108bacf4a974afaad0266c291ff9f2ab6f8af49294452314cbbeec1979c8e5ffab0860d87668f63d7d7731eb11eb3144a4bd0
+DIST hackport-0.8.4.0.tar.gz 2427117 BLAKE2B fac57e56cb09d32bd51abd5cb209920176682578cb198675d8dfca82b5b6851a5ea26758b9d83f3db74b5bc03a3ed9cb33372b56e9c314e3fdbb5fc24953e722 SHA512 4ecdc4e0eef0f27b4a79c4ad20676296d925fd51f113f701718f230ca9af2068bb44ef355cc0fdb22dceec11c2fe7aee14887bf2994d49f43bd5cfc66c9b7a79
diff --git a/app-portage/hackport/files/hackport.bash.completion b/app-portage/hackport/files/hackport.bash.completion
new file mode 100644
index 000000000000..687c2046c4c2
--- /dev/null
+++ b/app-portage/hackport/files/hackport.bash.completion
@@ -0,0 +1,14 @@
+_hackport()
+{
+ local CMDLINE
+ local IFS=$'\n'
+ CMDLINE=(+RTS -I0 -A8M -N1 -qg -RTS --bash-completion-index $COMP_CWORD)
+
+ for arg in ${COMP_WORDS[@]}; do
+ CMDLINE=(${CMDLINE[@]} --bash-completion-word $arg)
+ done
+
+ COMPREPLY=( $(/usr/bin/hackport "${CMDLINE[@]}") )
+}
+
+complete -o filenames -F _hackport hackport
diff --git a/app-portage/hackport/hackport-0.8.4.0.ebuild b/app-portage/hackport/hackport-0.8.4.0.ebuild
new file mode 100644
index 000000000000..d43064a77d5a
--- /dev/null
+++ b/app-portage/hackport/hackport-0.8.4.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +cabal-v1,+gentoo-tests,+pedantic
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal bash-completion-r1
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="https://github.com/gentoo-haskell/hackport#readme"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="profile"
+
+RDEPEND="
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/echo-0.1.3:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?]
+ >=dev-haskell/edit-distance-0.2.2:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hashable-1.0:=[profile?]
+ >=dev-haskell/http-4000.1.5:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/lukko-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?]
+ >=dev-haskell/network-uri-2.6.0.2:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parallel-3.2.1.0:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?]
+ dev-haskell/parser-combinators:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
+ dev-haskell/quickcheck:2=
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/regex-base-0.94.0.0:=[profile?]
+ >=dev-haskell/regex-posix-0.96.0.0:=[profile?]
+ >=dev-haskell/resolv-0.1.1:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1.7.0:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/tar-0.5.0.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-haskell/zlib-0.5.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/base-compat
+ >=dev-haskell/cabal-doctest-1.0
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ )
+"
+
+src_configure() {
+ if use test; then
+ export GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+ )
+ fi
+
+ haskell-cabal_src_configure \
+ --flag=cabal-v1 \
+ --flag=gentoo-tests \
+ --flag=pedantic \
+ $(cabal_flag profile profile)
+}
+
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+
+ # We only install bash completion scripts currently
+ newbashcomp "${FILESDIR}/${PN}.bash.completion" "${PN}"
+}
diff --git a/app-portage/hackport/hackport-9999.ebuild b/app-portage/hackport/hackport-9999.ebuild
index 7cc74ec9ca0f..dfd8f33c2cf4 100644
--- a/app-portage/hackport/hackport-9999.ebuild
+++ b/app-portage/hackport/hackport-9999.ebuild
@@ -1,72 +1,97 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# ebuild generated by hackport 0.7.1.1.9999
-#hackport: flags: +cabal-v1
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +cabal-v1,+gentoo-tests,+pedantic
CABAL_FEATURES="test-suite"
EGIT_REPO_URI="https://github.com/gentoo-haskell/hackport.git"
-inherit git-r3 haskell-cabal
+inherit git-r3 haskell-cabal bash-completion-r1
DESCRIPTION="Hackage and Portage integration tool"
-HOMEPAGE="https://github.com/gentoo-haskell/hackport"
+HOMEPAGE="https://github.com/gentoo-haskell/hackport#readme"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
+IUSE="profile +threads"
+REQUIRED_USE="profile? ( threads ) test? ( threads )"
-RDEPEND=">=dev-haskell/async-2.0:=
- >=dev-haskell/base16-bytestring-0.1.1:=
- >=dev-haskell/base64-bytestring-1.0:=
- >=dev-haskell/cryptohash-sha256-0.11:=
- >=dev-haskell/echo-0.1.3:=
- >=dev-haskell/ed25519-0.0:=
- >=dev-haskell/edit-distance-0.2.2:=
- dev-haskell/extensible-exceptions:=
- >=dev-haskell/hashable-1.0:=
- >=dev-haskell/http-4000.1.5:=
- >=dev-haskell/network-3.0:=
- >=dev-haskell/network-uri-2.6.0.2:=
- >=dev-haskell/parallel-3.2.1.0:=
+RDEPEND="
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/echo-0.1.3:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?]
+ >=dev-haskell/edit-distance-0.2.2:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hashable-1.0:=[profile?]
+ >=dev-haskell/http-4000.1.5:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/lukko-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?]
+ >=dev-haskell/network-uri-2.6.0.2:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parallel-3.2.1.0:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?]
+ dev-haskell/parser-combinators:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
dev-haskell/quickcheck:2=
- >=dev-haskell/random-1:=
- >=dev-haskell/regex-base-0.94.0.0:=
- >=dev-haskell/regex-posix-0.96.0.0:=
- >=dev-haskell/resolv-0.1.1:=
- dev-haskell/split:=
- >=dev-haskell/stm-2.0:=
- >=dev-haskell/tar-0.5.0.3:=
- dev-haskell/xml:=
- >=dev-haskell/zlib-0.5.3:=
- >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/regex-base-0.94.0.0:=[profile?]
+ >=dev-haskell/regex-posix-0.96.0.0:=[profile?]
+ >=dev-haskell/resolv-0.1.1:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1.7.0:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/tar-0.5.0.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-haskell/zlib-0.5.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=[profile?]
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- test? ( dev-haskell/base-compat
- dev-haskell/cabal-doctest
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/base-compat
+ >=dev-haskell/cabal-doctest-1.0
>=dev-haskell/doctest-0.8
dev-haskell/glob
>=dev-haskell/hspec-2.0
- >=dev-haskell/quickcheck-2.0 )
-"
-RDEPEND+="
- dev-util/pkgcheck
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ )
"
src_prepare() {
- default
- sed -e 's/^Version:.*/&.9999/' -i ${PN}.cabal || die # just to distinguish from release install
+ haskell-cabal_src_prepare
+ sed -e 's/^version:.*/&.9999/' -i ${PN}.cabal || die # just to distinguish from release install
}
src_configure() {
+ if use test; then
+ export GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+ )
+ fi
+
haskell-cabal_src_configure \
- --flag=cabal-v1
+ --flag=cabal-v1 \
+ --flag=gentoo-tests \
+ --flag=pedantic \
+ $(cabal_flag profile profile) \
+ $(cabal-flag threads threads)
}
src_install() {
haskell-cabal_src_install
doman man/hackport.1
+
+ # We only install bash completion scripts currently
+ newbashcomp "${FILESDIR}/${PN}.bash.completion" "${PN}"
}
diff --git a/app-portage/hackport/metadata.xml b/app-portage/hackport/metadata.xml
index bedf907374d9..168e097f4c4c 100644
--- a/app-portage/hackport/metadata.xml
+++ b/app-portage/hackport/metadata.xml
@@ -5,11 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A command line tool to manage an overlay of Gentoo ebuilds
- that are generated from a hackage repo of Cabal packages.
- </longdescription>
+ <use>
+ <flag name="profile">Enable profiling flags</flag>
+ </use>
<upstream>
+ <remote-id type="hackage">hackport</remote-id>
<remote-id type="github">gentoo-haskell/hackport</remote-id>
</upstream>
</pkgmetadata>