summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZurab Kvachadze <zurabid2016@gmail.com>2024-10-03 00:30:01 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-11-05 17:13:22 +0200
commit0e561b748a73b1b73dbe21b808d11e233d844960 (patch)
treef3ca721e6bb54290aae0aab8967769c9ad63fa96 /app-pda
parentsci-physics/rivet: add 4.0.2 (diff)
downloadgentoo-0e561b748a73b1b73dbe21b808d11e233d844960.tar.gz
gentoo-0e561b748a73b1b73dbe21b808d11e233d844960.tar.bz2
gentoo-0e561b748a73b1b73dbe21b808d11e233d844960.zip
app-pda/usbmuxd: add 1.1.1_p20240915
Bump the minimum version of the libplist to 2.6. The acct-user/usbmuxd dependency is moved to RDEPEND, as it is not required during the build. Closes: https://bugs.gentoo.org/924200 Signed-off-by: Zurab Kvachadze <zurabid2016@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38856 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/usbmuxd/Manifest1
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1_p20240915.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
index 17be1bb35aed..0e8c6e9da4e5 100644
--- a/app-pda/usbmuxd/Manifest
+++ b/app-pda/usbmuxd/Manifest
@@ -1 +1,2 @@
DIST usbmuxd-1.1.1_p20231011.tar.gz 65638 BLAKE2B 68bfdcdf907241fbf3b8b41133e11f3b08c5007417a1ea86f5428a5c11f480f9e6a6a9073080976d84ed14b456f61e19ef2b2f161d5b1ec19367fe01eb89b435 SHA512 dfe2e39496aa6841aaa7c02dc5ad5425f4199d5e5ccf560438e5f07fff9050124918ce99a1b2e22fc5b8718e091aff81ff209467de16701a14279e994c5ceefe
+DIST usbmuxd-1.1.1_p20240915.tar.gz 65629 BLAKE2B 20959476ea71614395fbfc17f4ed32da2cdbf6d92116549fe7d68f8f39ed9cb6c952c72e6ba86cc4885a923de159256c5a53d04c976631a966e1b0cf3eca5718 SHA512 1c50ca5827f90c901850aff7d222a8bcdb450ade698be1586ba157e9a3039a147d93a14fde14d6605a3d45907ae9716d06ed19a3230e3d51c3b3fb12334f0400
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1_p20240915.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1_p20240915.ebuild
new file mode 100644
index 000000000000..1ae31427df89
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1_p20240915.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd udev
+
+MY_COMMIT=0b1b233b57d581515978a09e5a4394bfa4ee4962
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/usbmuxd/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="selinux systemd"
+
+DEPEND="
+ >=app-pda/libimobiledevice-1.3.0:=
+ app-pda/libimobiledevice-glue:=
+ >=app-pda/libplist-2.6:=
+ virtual/libusb:1=
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/usbmux
+ virtual/udev
+ selinux? ( sec-policy/selinux-usbmuxd )
+ systemd? ( sys-apps/systemd )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ echo ${PV} > "${S}"/.tarball-version
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "$(use_with systemd)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}
+
+pkg_postrm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+}